Back to the main site

[Solved] Origin blank welcome screen with i3


#1

I used multiple Origin installers (Origin, Titanfall 2, Battlefield V) but I never anything but a blank screen from Origin.

neofetch :

██████████████████  ████████   shaah@belhulrae 
██████████████████  ████████   --------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: MS-7A34 1.0 
████████            ████████   Kernel: 4.19.18-1-MANJARO 
████████  ████████  ████████   Uptime: 2 hours, 33 mins 
████████  ████████  ████████   Packages: 1185 (pacman) 
████████  ████████  ████████   Shell: bash 5.0.0 
████████  ████████  ████████   Resolution: 1600x900, 1920x1080 
████████  ████████  ████████   WM: i3 
████████  ████████  ████████   Theme: Adapta-Nokto-Eta-Maia [GTK2/3] 
████████  ████████  ████████   Icons: Papirus-Adapta-Nokto-Maia [GTK2/3] 
████████  ████████  ████████   Terminal: urxvt 
████████  ████████  ████████   Terminal Font: 9x15, xft 
                               CPU: AMD Ryzen 5 1600X (12) @ 3.041GHz 
                               GPU: NVIDIA GeForce GTX 980 
                               Memory: 4297MiB / 16053MiB                                           

Pastebin : https://paste.ubuntu.com/p/nyQSQSwYFJ/


#2

Could you give this a try?


#3

Done, didn’t change anything.


#4

Are you behind a proxy? Or is there any Proxy Settings it could try to use?
Something like this?


#5

Nope, no proxy, no proxy settings.


#6

Can u try to uncheck “Enable DXVK”


#7

Still doesn’t change anything.


#8

Rendering issues could be due to corefonts not being installed in the wine prefix. For comparability sake change the windows version to windows 7.To fix this run the following terminal commands. WINEPREFIX=~./wine winetricks corefonts win 7. Replace ~./wine with your wineprefix where origin is installed. This also fixes other launchers like uplay.


#9

Issue still not resolved.

The fonts were clearly missing, but I still get a blank welcome page.

I’m trying out the legacy version of origin on windows vista now, will update.


#10

Alright.

Legacy version (9.13) on vista at shows some stuff and looks functional. However the game I want to play cannot be downloaded/played in Windows Vista …


#11

Had the same problem. Had to install all optional dependencies for wine (https://www.gloriouseggroll.tv/how-to-get-out-of-wine-dependency-hell/). After that the Battlefield V script works as it correctly sets up dxvk with nvidia (a 2 lined dxvk.conf). Without that config it only opened with dxvk up to 0.92.


#12

So, fresh install, Win 7, corefonts installed, Wine 4.0, dxvk disabled : still blank origin homescreen screen.

Console output :

wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
[8:9:0207/163609:ERROR:network_change_notifier_win.cc(156)] WSALookupServiceBegin failed with: 8
ALSA lib seq_hw.c:466:(snd_seq_hw_open) open /dev/snd/seq failed: Aucun périphérique de ce type

#13

I resolved it.

In short, it’s an “issue” with i3.

Origin is actually composed of multiple smaller windows. Of course, i3 will tile that making the main origin window look empty. Genius level design.

Therefore, for all you dumbasses like me using i3 to run origin in wine ( … ) you just have to add

for_window [instance="origin.exe"] floating enable

to your i3 config file.


#14

Cool you found a solution. I’ll add it to the wiki page.