Back to the main site

[Solved] No sound from Wine


#1

I have somehow killed sound in wine from my various recent updates to linux mint 18.3.

Kernel: 4.15.0-36-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia

I get no sound from the dosbox game Shadow Warrior, from Morrowind, or from Guild Wars 2 which I just got installed. There is no sound from the test sound on wine configuration either. Except for Guild Wars the other games did have working sound. I had to run GW in a virtual desktop, but changing that setting had no effect on the other games. I just tried my old copy of world of warcraft using plain wine and no sound from the cinematics.

I have tried auto, pulse, alsa, and oss in the configure wine tab of lutris. I have tried installing almost every pulse library that seemed remotely close to what I needed using the package manager. My best guess is it is a simple library issue, but I don’t know how to fix it. I am not a linux expert by any means.

The audio configuration from my system is below.
Audio: Card-1 NVIDIA GK208 HDMI/DP Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2
Card-3 Logic3 driver: USB Audio usb-ID: 005-002
Sound: Advanced Linux Sound Architecture v: k4.15.0-36-generic

I will include the debug output from lutris, but I don’t think it is a lutris issue at this point.
https://paste.ubuntu.com/p/Wr3c6JRR7h/


#2

Somehow messing around in winetricks I got it running.