[Solved]No mans Sky Next missing Textures/Assets, and build menu broken

EDIT: So not ive discovered that the build menu just doesnt work, attempting to build your base will result in crashing

So recently decided to switch back to Ubuntu on my main Desktop

No Man’s Sky runs well minus this slight annoyance of Doors, Freighter parts, and Glass/ Transparent surfaces all missing their textures. It doesnt prevent play but is obviously annoying

https://imgur.com/buzKIFU

https://imgur.com/qjQi0CG

https://imgur.com/VfaCDSr

https://imgur.com/26HxAwO

Is anyone else having this issue? Does anyone know of a solution?
Now Im not very familiar with getting things going in Wine but Im not a newbie with Linux and have used it quite a bit for server hosting, VM, etc. so i can definitely follow any solutions people might provide (if any).

System Information

Wine 3.12-staging and 3.13-staging (also went back to 3.9-staging to give it a try)
Ubuntu 18.04 with Vanilla Gnome desktop, newly installed and updated
Nvidia 390.77 driver (also tried with the 396 driver)
4770k
16gb ram
GTX 1060 6gb

Im having the same problem with mine to but mine doesnt even show anything. Its just a white screen with lines. so your not the only one.

1 Like

I fixed the issue. The previous Installer would setup a prefix in the game folder. This would break the game causing assets not to load and the build menu crashing issue

All you need to do is simply install NMS like normal and it’ll work perfectly. I made the edits to the installer to fix the issue

If you have an AMD GPU, just forget it, they’re using a Compatibility profile that will never be implemented by Mesa, as per the Mesa developers. Maybe Hello Games can change it in the future, but who knows?