Back to the main site

[Solved] Need help launching a game with custom locale

I have a Japanese Windows game that requires it to be run in Japanese locale. So to properly launch it I need to use the terminal and execute LANG=ja_JP.UTF-8 wine /path/to/the/game/executable.exe command. Where do I append LANG=ja_JP.UTF-8 wine in Lutris game configuration so that I can launch the game from Lutris dasboard?

Wine is supposed to be used via Wine runner:


You may want to put in the correct wineprefix in the Game Options tab (in my experience, Japanese games seem to work better if the prefix they’re being run in has been created with Japanese locale). Also, placing /path/to/the/game/ into the workdir field is normally a good idea.

As for custom environment variables, they can be set up in the System Options tab of the game config:

Thank you for the reply.
After adding environment variable I am now able to run the game through the Lutris dashboard.
However, the font in Wine dialogue isn’t rendered properly.
Screenshot_20190711_234827
(This is window close confirmation dialogue)

Is this because I’m using the default prefix?

Most likely… In Windows, to run CJK applications you need to do install some additional stuff, so trying to run them in a regular wineprefix can easily produce problems like this. For that reason, I usually keep a separate wineprefix for Japanese stuff (or rather, actually two: 32-bit XP and 64-bit Win7).

If the problem persists afterwards, it’d mean you need to install some CJK/full-range unicode fonts, either in your system or via Winetricks. (Although IIRC Wine installs basic CJK fonts into wineprefixes created with appropriate locale.)

Some games, however, may have font problems even after wineprefix fixes them. (One game I tried out recently displayed all game text as squares, unless the text was produced by skipping the “gradual typing” animation… in which case only first letters of words were squares :confused:) So I’d suggest checking the wine apps first, like winecfg or file explorer… though lately winecfg has been showing English text even in Japanese locale, but it’s still changed to monotype, and dates in file property dialogs are still displayed in Japanese format (2019年7月12日).

The game now runs properly with the combination of adding LANG | ja_JP.UTF-8 as environment variable, creating a prefix via winetricks with Japanese locale (had to change Kubuntu’s system formats to Japanese first for this), then installing all available fonts for the new prefix, and finally revert Kubuntu system’s formats to my preferred choice.

Thank you very much! :grin: