Back to the main site

[SOLVED] My Graphic card is not seen by Lutris

Good evening (evening for the ones sharing my time zone).

I’m discovering the delight of playing one Linux. CS with the native Steam software, Call of with “Play On Linux”, PES with a single wine, GTA V with Lutris…
But OK, that the price for freedom.

Everything is OK (except key or joy-pad mapping) with the 3 first solutions, but with Lutris I’ve a problem: my graphic card is not recognized by Lutris. Nor by the game launched from Lutris. So nor by GTA, meaning I can play 5 minutes before lag, 10 minute before crash.

I’m using Lutris 0.5.7.1 from an Ubuntu 20.04.1 LTS, and I’ve set up the nvidia-driver-450-server

Ubuntu says (lspci -nnk | grep -iA2 vga):
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 630 [8086:591b] (rev 04)
Subsystem: Acer Incorporated [ALI] HD Graphics 630 [1025:1196]
Kernel driver in use: i915

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev a1)
Subsystem: Acer Incorporated [ALI] GP107M [GeForce GTX 1050 Mobile] [1025:1199]
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

While Lutris says:

  • [Graphics]*
    Vendor: Intel
    OpenGL Renderer: Mesa Intel® HD Graphics 630 (KBL GT2)
    OpenGL Version: 4.6 (Compatibility Profile) Mesa 20.0.8
    OpenGL Core: 4.6 (Core Profile) Mesa 20.0.8
    OpenGL ES: OpenGL ES 3.2 Mesa 20.0.8
    Vulkan: Supported

Where/How can I help Lutris to use the correct device ?

Thanks, Gaillac.

PS: I’m not a native English speaker, sorry for mistakes.

The GPU part of lutris-issue-report.json:

And on the Ubuntu side:

lspci -vnn | grep -A 12 ‘’’[030[02]]’ | grep -Ei “vga|3d|display|kernel”

lspci -vnn | grep -A 12 ‘’’[030[02]]’ | grep -Ei “vga|3d|display|kernel”

I don’t have an integrated GPU on my CPU, but I think you should take a look at this article, the problem probably is that by default your integrated GPU is the default GPU for the X windowing system, the topic I will link too is talking about making sure that the addon/discreet GPU card is default, and the onboard GPU is not, and only used as linked through.

https://forum.winehq.org/viewtopic.php?t=30494

Maybe it is possible to tell X to use the integrated GPU on the desktop if that is what you want to save power or what ever while it is not the default, rather then the other way around to try to tell Wine to use the discreet graphics card while the onboard is default.

Thank you vuurdraak.

I tried the demurgos solution, creating 3 files (with gdm instead of sddm). Then I couldn’t log anymore on Ubuntu. I remove the files from an Ubuntu recovery session, and my computer restarted normally.
About the Bob Wya suggestion, Linux kernel boot option, I just didn’t understand it.

NB: if I launch the Nvidia X Server Settings app, the selected option is NVIDIA (Performance Mode). I’ve tried NVIDIA On-Demand without noticing any change (after restarting of course).

Hello.

I’ve solved my problem.
The radical way.
I’ve changed my Linux distribution, from Ubuntu to Mint.
Successfully on my graphic card point of view:

[Graphics]
Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GTX 1050/PCIe/SSE2
OpenGL Version: 4.6.0 NVIDIA 455.38
OpenGL Core: 4.6.0 NVIDIA 455.38
OpenGL ES: OpenGL ES 3.2 NVIDIA 455.38
Vulkan: Supported

However, my problem is solved.