[Solved] MTG Arena Not Working After 16th August Update

Hi all

I was playing MTG Arena with very few problems using the latest installer from Lutris but when the most recent update happened things went wrong. I ended up with just a black screen and nothing seemed to happen no matter how long I left it.

I tried a fresh install and it seemed to go well with the usual popups and having to restart a few times to get the assets to update. The problem is that it now gets to downloading and installing the last 2 assets and just keeps freezing there, where usually it freezes but picks up next run.

Will there be an updated installer or does anyone smarter than me about wine know of a fix?

The game is made in Unity and they are talking of other platforms further down the line (it is still in closed beta at the moment) but I suspect this means iOS and Android and maybe MacOS X with Linux as a very last thought.

I’ve just experienced the same. Since I played in windowed mode and it got to fullscreen automatically, I suspect they restarted or put graphics settings to do default.

I tried hunting down some kind of graphics settings file, but nothing works.

When running Lutris in a terminal, the game outputs no debug data.

Trying to run on staging 3.13 no DXVK or Gallium Nine or whatever… I hope somebody has a solution.


I was having the same error, I ended up having to delete and reinstall the game a couple times before it just simply worked again, the first run after the successful install I got a sound glitch but now it works fine.

There’s a delay at the start where a transparent screen appears, you notice the game is running because your mouse pointer changes, then it starts as usual.

I\m currently running with the default configs from the package.

I have tried to reinstall 2 or 3 times since with no luck. What wine version are you using and are you using the defaults from the Lutris installer?

Just reinstalled the “latest” version (not the fork) and it is working again. Having tested a game because I don’t have time, but I wanted to see if the installer and getting into the main menu was ok.

I had a couple “Path not found” or “Application Crashed” errors during installation, but simply starting it up again solved the problem.

Weird - I just tried again and it worked this time, I suppose the answer is to just keep trying :-/

I spoke too soon - the game goes to the menu but I can’t actually join a match. I will try again later in case it is something at their end - there was some server maintenance tonight apparently.

EDIT: I tried later and it seems to be fine now. Fingers remain crossed.

Possibly, we tried playing when the game was about to go into some maintenance or the patching server was down.

EDIT: it seems you can’t properly multitask anymore. I usually play on windowed mode, and I just went to this browser and back to the game and everything was unresponsive. Mouse+keyboard didn’t do anything, no audio whatsoever.

If this happens during the game, you’ll be in a state where you can only wait for the auto-concede.

I’ll try to keep playing fullscreen and see if this happens fullscreen with no alt+tabs

I had this but it was OK once I used a virtual desktop.

Why is MTG Anena always end up “Not responding” every 10 seconds in a magic duel? Every time it does it, I end up losing my attack phase and lose every match due to this! LMK what I need to do!