[Solved] Manjaro Gaming Edition Fresh Install - Lutris doesn't work

Hello all !

So I’ve just installed Manjaro Gaming Edition. I didn’t knew what Lutris was during my investigation for a Linux distribution, but I quickly found out it would be very helpful.

Unfortunately, out of the box, after a fresh install of Manjaro Gaming Edition, Lutris doesn’t seem to start. I launched it also in a terminal to see if I could get a result and this is all I’ve been able to get :

File “/usr/bin/lutris”, line 43, in
from lutris.migrations import migrate
ModuleNotFoundError: No module named ‘lutris’

I checked on line 43, and it contains : from lutris.migrations import migrate

I’ve removed Lutris and reinstalled it using pacman, but no change in Lutris. I’m not very sure what happens here. Care to share your ideas ?

Thank you,

Edit : I’ve been searching on the forums and googling my error, and found out a message mentioning that he had reinstalled Lutris. This seems to have solved the problem. For those who wants it, here is the link : ModuleNotFoundError: No module named ‘lutris’

The solution there didn’t worked for me, and I keep getting the same error as before. But I went and checked in the python installation folder. I found lutris and another file linked to lutris in python 3.5. I also found an installation of python 3.6 with a lot of files in there. I don’t know though if I can move files from the python 3.5 to the 3.6.

Not sure what I can do there. Should you have any idea, feel free to let me know !


Dear all,

Problem is solved. I just managed to start Lutris without problem. Here is what I did, from within Manjaro.

  • uninstall Lutris from the Manjaro add/remove software
  • launched yaourt and installed from the AUR instead of the Manjaro repo
  • Followed the standard process until it completed the installation
  • Launched Lutris without a problem.

I hope this will help other to solve their issues :slight_smile:

My guess is that the version of Lutris in the repos is out of date. Just be aware that you aren’t using an official spin of Manjaro, and Lutris isn’t even in the repos of the official Manjaro versions. So the pacman version actually comes from a third party repo. I believe that the AUR version is maintained by the actual developers, so it is always up to date.

If this is the case, can someone get in touch with the Manjaro and tell them to stop distributing outdated versions of Lutris right now?

As I mentioned previously, he isn’t using an official version of Manjaro, and the official versions of Manjaro do not distribute Lutris in the repos. Manjaro Gaming Edition is a third party respin - pretty much like the plethora of Ubuntu “distros” which are literally Ubuntu with a fancy wallpaper. This is the sourceforge page.

Gosh, these custom spin distros are a complete waste of time.

Just for my own understanding… After all your comments, I believe it is better for me to use Manjaro (or Arch even though I’m not sure about all the everything I need to do and what package do I need) rather than sticking on the Manjaro Gaming Edition ?

I don’t mind changing, I didn’t did much on the installation and would rather have something that is official (like made by the developper) rather than a solution I will work with for as long as someone is updating it.

I had understood this was a community based edition much alike the Deepin, but it seems not to be so. If not official, I would definitely change for something more streamlined.

Thank you for your insight, and my apologies for the trouble.

Edit : Just for the little story, I’ve reinstalled my system under legit Manjaro. I picked the Gnome Edition( to go with my tastes) which is from the developper, without weird third party packages association. Normally this should resolve any of my problems now.

Thank you for your time and guidance, and apologies for the trouble.

Edit 2 : Thank you. From Manjaro, Lutris was a breeze to install. Keep up the good work guys !