[SOLVED?] Lutris won't start, no error message

I decided to try to use Lutris today after some time and for the life of me I can’t get it to run, I’ve deleted all these folders: .local/share/lutris .cache/lutris and .config/lutris to no avail, running Lutris shows no error message, even with lutris -d all I get is this:

INFO     2019-05-20 12:19:31,954 [application.do_command_line:225]:Running Lutris
INFO     2019-05-20 12:19:31,955 [startup.check_driver:60]:Using X.Org
INFO     2019-05-20 12:19:31,955 [startup.check_driver:65]:Running Mesa driver 19.0.3 on AMD VERDE (DRM 2.50.0, 5.0.10-arch1-1-ARCH, LLVM 8.0.0) (0x683f)
INFO     2019-05-20 12:19:31,955 [startup.check_driver:75]:GPU: 1002:683F 1682:3242 using radeon drivers
INFO     2019-05-20 12:19:32,062 [startup.check_vulkan:131]:Vulkan is not available or your system isn’t Vulkan capable

It doesn’t crash, it just sits there and the window never opens.
Just for the sake of it I tried running it as root… and oh surprise, it works just fine, for reasons.

I’m running Arch Linux x64 and as you can see above Lutris
I will provide any additional information if needed, thanks in advance.

It is suddenly working now, after doing, absolutely nothing. Solved I guess.