Back to the main site

[Solved] Lutris won't open, no errors in terminal

Hello there,

Lutris was running fine on ubuntu Focal Fossa and it was great. Then after a ubuntu automatic update It does not work anymore.

The weird thing is that either with lutris command or lutris -d in terminal it does not print anything.
It just wont give me back the prompt line…

Can you be of any help to debug this please ? I would like to provide the lutris-issue-report.json file but I don’t know how i can upload it to you.

Many thanks in advance.

In theory, you could run the Lutris binary (on my system it’s installed as /usr/lib/python-exec/python3.6/lutris) in python debug mode (python -v <path-to-script>), but that’d just generate a very long output, so good luck finding useful information in that.

Rather than that, I would first check if that update broke some version matching (like GTK-Python interop layer, or for example it replaced your Python version without reinstalling Python packages like Lutris for it). If that’s the case, you can reinstall whatever wasn’t updated to make it work together again.

Many thanks for your answer,

Running python3 /usr/games/lutris provided me an error I saw before :

File “/usr/lib/python3/dist-packages/lutris/gui/views/store.py”, line 133, in init
self.modelsort = Gtk.TreeModelSort.sort_new_with_model(self.modelfilter)
AttributeError: type object ‘TreeModelSort’ has no attribute ‘sort_new_with_model’

So I updated the store.py code with this one (the ‘try except’ part):
https://git.archlinux.org/svntogit/community.git/tree/trunk/sort_new_with_model_fix.patch?h=packages/lutris

And it worked well. Maybe the source code should beupdate or I have an old version of it ?

There’s a weird issue with GTK just renaming a function between versions without providing a “deprecated” fallback version, which breaks on update all software that didn’t expect the name change. I had the opposite problem (Lutris renamed the function before the stable GTK package added the rename… or maybe it’s the other way around?), so I ‘downgraded’ the call manually, until the next update.