Back to the main site

[SOLVED] Lutris doesn't want to install "Star Wars: The old Republic"


#1

trying to install https://lutris.net/games/star-wars-the-old-republic/, right after I click the “Continue” button in the lutris install wizard page where you select $GAMEDIR, it pops up with wine is not available for the x86_64 architecture and aborts the install, even though the wine version used in that very installer actually is staging-2.20-x86_64.
this version doesn’t show up as available in “manage wine versions” though, is the version used in the installer just outdated?

Edit: it was exactly that, changing the version to 3.3-x86_64 fixed it, so I sent a fork to moderation.
that error message is pretty misleading though.


#2

I’ve updated the script but, in the future, if you’re just editing an existing script to change the wine version then just edit it. Only fork an installer if you’re doing something drastic like changing the runner.


#3

oh sorry, I didn’t really get the UI at the first glance (also now I have 2 unpublished forks because I accidentally reloaded the fork page), it was pretty much my first interaction with the site, won’t happen again :smiley:

on another note btw: I spent waaay too much time last night to “test” the new installer (= play to like level 20 and 3 planets into the story) and I can say, having last played SWTOR about a year and a half ago, the performance and stability in wine has improved from “it only runs with a helper that messes with the process ram and if you even look at the map everything dies” to “runs better, faster and more stable than on windows”