[SOLVED ]Lutris doesn't launch anymore

As of today Lutris doesn’t launch anymore:
OS: Arch Linux
Kernel: 5.10.10-arch1-1
DE: GNOME 3.38.3
CPU: AMD Ryzen 5 2600 (12) @ 3.400GHz
GPU: NVIDIA GeForce GTX 1660

Latest update broke for me as well, trying to run it from CLI I get this

Traceback (most recent call last):
File “/usr/bin/lutris”, line 52, in
from lutris.gui.application import Application # pylint: disable=no-name-in-module
File “/usr/lib/python3.9/site-packages/lutris/gui/application.py”, line 41, in
from lutris.gui.installerwindow import InstallerWindow
File “/usr/lib/python3.9/site-packages/lutris/gui/installerwindow.py”, line 17, in
from lutris.installer import interpreter
File “/usr/lib/python3.9/site-packages/lutris/installer/interpreter.py”, line 14, in
from lutris.installer.installer import LutrisInstaller
File “/usr/lib/python3.9/site-packages/lutris/installer/installer.py”, line 16, in
from lutris.services import get_services
File “/usr/lib/python3.9/site-packages/lutris/services/init.py”, line 2, in
from lutris.services.gog import GOGService
File “/usr/lib/python3.9/site-packages/lutris/services/gog.py”, line 9, in
from lxml import etree
ModuleNotFoundError: No module named ‘lxml’

Hello @jimsjoh, you need to install python-lxml package


thanks, solved the issue for me.
Is a new dependency? Not sure if it was installed from before, but never removed it manually at least.

How can i install the python-lxml3 package on Arch?

in a terminal type:
sudo pacman -S python-lxml
source: https://wiki.archlinux.org/index.php/pacman#Installing_specific_packages

1 Like

The Arch community package is currently broken for various different reasons. The maintainer isn’t paying any attention at all to upstream. For now, I strongly suggest using the lutris-git AUR (Arch User Repository) package. I’m the maintainer, by the way.

Thank you!

Does this apply to Arch-based distro’s such as Manjaro?

Probably. Lutris team contacted Arch packages maintainer, it should be soon resolved.

Manjaro is still currently using lutris- package revision, which would be the same as Arch’s at the time. Arch is now at package revision, incremented due to “add missing python-lxml dependency”

I use Manjaro, but mine is heavily gutted and customized and I build a lot of my own packages. I have lutris in my IgnorePkg list now and I roll my own using Arch’s PKGBUILD so I have been using lutris Some annoyances have been fixed since