Back to the main site

[SOLVED] Lutris as sudo user

I hope it’s in the right category :slight_smile:
I was searching how to add Lutris to the sudoers because in the user mode I can’t run Battlefield 5 without sudo. When I start Lutris with sudo there is another configuration of my games… So I don’t want to be sudo as my user and I want to run Lutris as sudo automatically. I know that VLC is doing a thing like I would like to (they have an user account for their program). Please help me :slight_smile:
Thanks

No no no no no…

You use sudo to make system changes. A game that asks for root permissions means there is something else that’s wrong.

Your games should be installed in a location owned by your user account. Your home directory for example.

When you run Lutris as root, all files created will be owned by root and thus when you run Lutris using your own account Lutris can’t access those files anymore.

Battlefield V doesn’t have a Linux version, right? So it runs in a Wine bottle. The game shouldn’t even know there’s a root account on the machine.
You might have problems with file access (file/folder ownership, as well as access bits), or with device access (the new gamepad interface is only available to members of input user group, for instance). Try to figure out what could be the cause (and definitely never run the installer as root or any other user than your own for that matter).

1 Like

Yes, exactly.

Sorry if our reactions come over as a bit harsh. We’re trying to keep you safe here. :slight_smile:

When using su or sudo you are giving an application god mode on your machine. That should be a standard access denied from your side.

1 Like

I have to run origin as root because else it doesn’t let me run it.
It gives me :"[Errno 13] No rights: '/home/lukas/data/games/user.reg
I tried to chown it to my user but it didn’t worked. so now I’m opening lutris with sudo and it works for now. But I dont want to everytime sudo lutris you understand ?
:slight_smile:

I know. Because of that I want to find a solution somewhere because I can’t run origin without root :frowning:
thanks for your reply :slight_smile:

now i tried to chown it again and it worked ^^ thanks anywhay :))

Yay! You’ve got it. :sunglasses:

Happy gaming under Linux!