Back to the main site

[SOLVED] [League of Legends] Stuck at Authenticating stage (Login)


#1

I tried changing regions to Russia, EUW, EUW&N, Brazil(?), etc…
Still cannot login, but download is progressing as I can see 1% changes to 4%, so on.
I am on a 64bit Arch Linux install. This is the first time I’m trying Lutris, and also installed every dependency using the command from “How to escape dependency hell”.
Please help me connect properly and get this working. I’ll be so happy with this if it works… (I don’t like using Windows)


#2

Hello there,

Which version did you choose to install ???

Cause the OpenGL script no longer work you have to install the directx one then setup OpenGL manually in the game.cfg by adding x3d_platform=1 under the [General] section.

The install gonna takes a long time unless you have a backup of the game so be patient. :slight_smile:


#3

I chose to install the NA version, and from the link which is in the lutris website. And where is the game.cfg file located?
Also, I can see the new client. The only problem is that when I login, it is stuck at “Authenticating…”


#4

Ok, I changed region to EUW and it restarted and updated itself. Now it simply logged in when I entered the credentials after a short wait. Maybe the connection to NA servers was too long. The solution seems to be “Try other servers”, simply.
(I’m playing from India, btw)…


#5

In game Config folder.

You can accessed it directly by right clicking on the game in Lutris > Browse files.

Also if you had a computer that can handle Windows 7, Select Windows 7 in Wine settings, CSMT should be set by default.

Cya.