[Solved] League Of Legends Crashing After Login

Sooooo, after a lot of hassle I managed to install League Of Legends through Lutris, but now even after doing everything as the guide says (closing the Riot Client after the patch) it crashes after I log in.
I come online for others for a bit, and the big League Of Legends logo appears on my screen for a bit, but at that point it crashes, every, single, time.
My cpu usage also skyrockets when that happens, but I don’t know what to do now. Is it even possible to fix this?

System Specs:
OS: POP_OS 21.04 LTS (nVidia)
CPU: Intel Core 2 Quad Q9400
GPU: nVidia GeForce GTX 750Ti
RAM: 8GB x DDR3 1333Mhz

If there are logs about crashes like that or something, please tell me where I could locate them and I’ll include them in the post, but right now I just don’t know where are they stored.

I don’t know about that specific game, but you are going to have trouble with a Core 2 processor nowadays, as it lacks popcnt and the newer SSE instructions (and obviously no AVX but that’s not a hard requirement here)

As soon as you run into an unsupported instruction, blammo. It doesn’t necessarily happen right away in game, but will occur every time when triggered by an event.

In system requirements, they aren’t going to tell you that, say, “Patch level 2.3 is going to make the game incompatible with older CPUs that were getting away with it before”

I don’t play this game, but I did a bit of searching. Threads from years ago cite “SSE 2” in system requirements, but I just looked at Riot Games’ posted minimum CPU requirements and they have changed to “Core i3-530” and “SSE 3” as minimum requirements.

Yours SHOULD support SSE 3 (up to SSE 4.1) but may not support other features that could have crept in. They list “AVX” in recommended requirements, so that means the game does CPU detection and enables code paths accordingly, so there’s more than just “SSE 3” supported.

Personally, I’m having trouble with AVX creeping into things. I have a Nehalem Core i7 that’s otherwise just fine but game patches can introduce it, even if not deliberate. Microsoft’s asshole compilers default to generating those instructions I think.

Nowadays you need to heed specific CPU requirements. Often if it lists a specific model for the minimum, it’s because it’s the first one that supports certain instructions. Until recently I wouldn’t have even read system requirements because I was going to ignore them anyway.

To get a log, start lutris in a terminal with the -d switch

lutris -d

Go to Runner Options of the game and check the box to show Advanced settings. Enable debugging (I wouldn’t enable “full” as it may generate hundreds of megs of crap and cripple your machine while its doing it)

Attempt to play your game. After it crashes and aborts, go to Show Logs in the little arrow activated menu for the game.

Another thing I should mention. The Lutris wine runners that have “lol” in the name are tweaked for League of Legends. Make sure you are using the right runner e.g. lutris-ge-lol-6.16-3

@Grogan it indeed was my cpu compatibility
I’ve got a less old amd processor from one of my friend that he didn’t use anymore, and with that it works flawlessly, and I can run basically everything so far that I tried

Thank you for point that out for me, cuz otherwise who knows for how much longer would have I tried to make it work with that cpu

Yes, that can really have you chasing your tail, especially when there’s no obvious indication the problem is that. Somewhere in the wine log output, you’d find a game process crashing with an illegal instruction type error.

I’m glad you were able to get something put together, I’m certainly not in the market for a system upgrade with today’s prices (and not just because of inconsiderate devs either).