*SOLVED* Leage of Legends error with libgstflac

Hello together,

since a few Days i cant run lol on my OpenSuse Desktop. If I start into a the launcer, i get the following error:

(wine:1131): GStreamer-WARNING **: 22:11:35.244: Failed to load plugin '/home/XXX/.local/share/lutris/runners/wine/lutris-ge-lol-8.7-1-x86_64/lib64/gstreamer-1.0/libgstflac.so': libFLAC.so.8: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden

If I open the folder from the error, the file is in place. I reinstalled Proton, Lutris and Lol.

The Hole Debug Log:


It would be a pretty old distro (older Ubuntu) to have libFLAC.so.8, that plugin is going to fail for a lot of people (It’s seen a lot, but not fatal unless actually using the FLAC back end)

I don’t know anything about LOL, but it’s possible it actually uses that plugin and the game fails.

Possible solution to the libgstflac problem would be to drop an older libflac (.so.8) in the game directory, or even one of the system library directories, but most games do set LD_LIBRARY_PATH to their own directory for bundled libraries.

OpenSuSE is a rolling distro if memory serves, but it looks like you can grab a libflac8 package here


Alternatively, compile one and install the results to an alternate directory (e.g. DESTDIR=) and take the library and name it libFLAC.so.8

This doesn’t directly help, but it helps to understand the problem.

See, these lutris-ge runners are protonified wine. They are build in containers (or virtual machines for some of the builds I’ve looked at), with old toolchains, against old libraries.

That’s fine and dandy to use Valve’s toolchains and environment when used with the Steam runtimes (Soldier, Sniper and the ubuntu_12 steam runtimes all have libFLAC.so.8) but trying to run it in your native environment, without it being somewhere in a runtime path (e.g. LD_LIBRARY_PATH variable) it will fail.

Now, current Lutris DOES supply a Steam runtime with libFLAC.so.8 (both 32 and 64 bit), but the runner would actually have to be using it.

Do you have lutris-0.5.13 or a distro package of an older one?

If you have the latest lutris and it’s present, you could try setting LD_LIBRARY_PATH there, for example


If you don’t have Lutris 0.5.13, you should try to get that, it may just work.

Ok I found a soluition.

Your answer was correct, the flac extension was missing. I Installed it and the error is fixed.

But these error was my main error. My problem was a missing xorg.conf. No idea why, but the file was missing. I used the command

sudo nvidia-xconfig

an nvida-xconfig wrote the x11conf new. After a restart lol works.

Thanks for Helping!!!

1 Like

Yeah, those proprietary drivers still need xorg.conf configuration to use them. Otherwise nouveau for Nvidia.

I thought the libFLAC thing might have been a red herring, but then I searched around and found that LOL does have FLAC audio files for the soundtrack and wondered if FLAC was somehow being used internally as well.

Thanks for coming back with your solution.

I just ran this but I don’t use xorg, so it made my system unbootable :sweat_smile:

Luckily I could switch TTY with ctrl+alt+f2 and delete the file it created.