Back to the main site

[Solved] Issues running vulkan titles


#1

I have followed the instructions to install vulkan however when i try to run titles with dxvk for example Grand Theft Auto 5 i get this error “No directX 10 or 11 adapter or runtime found”

I’m currently running on a Dell Latitude E5550:
Geforce 840m (which should be compatible according to: https://developer.nvidia.com/vulkan-driver)
driver: 430.14

lutris seems to say it is supported when running lutris -d
INFO 2019-06-08 22:44:45,487 [startup.check_vulkan:129]:Vulkan is supported
running vulkaninfo returns some info ending with:

Presentable Surfaces:

=====================
GPU id       : 0 (GeForce 840M)
Surface type : VK_KHR_xlib_surface
/build/vulkan-tools-1.1.106.0~rc2/vulkaninfo/vulkaninfo.c:1518: failed with VK_ERROR_INITIALIZATION_FAILED

Full log is available here: https://pastebin.com/YD2ekGXJ
Any help would be appreciated


#2

Your problem appears to be with DXVK and not vulkan.
Have a look at https://github.com/lutris/lutris/wiki/How-to:-DXVK and
https://github.com/doitsujin/dxvk/wiki/Common-issues

You may want to check if the dlls are in your WINEPREFIX/drive_c/windows/syswow64 and system32


#3

Which dlls should i look for? I’ve searched for vulkan in both folders and they both return “vulkan-1.dll” and “winevulkan.dll” thank you for the link to the common issues, hadn’t found that in my search and it made me check the <game>_d3d11.log which seems like it may have some useful info since it ends with:

err:   Failed to create swap chain
err:   D3D11CreateDevice: Failed to create swap chain

here’s the full log if it is of use:
https://pastebin.com/t4Zdt4ki

Are you sure it isn’t a vukan issue since vulkaninfo is only testing vulkan righ? or should i not mind that error.


#4

Check in your $HOME/.local/share/lutris.old/runtime/dxvk/${version}/ under x32/ and x64
I think you are supposed to run ./setup_dxvk.sh $WINEPREFIX (path to your wine prefix) from there.

Lutris does this for me effectively on its own, so I am not completely certain of the manual way, but this is what I gather from what I have read.


#5

Was I responding to the wrong post? Oh dear!


#6

Haha no problem I’ll take any help i can get.


#7

Quick update, for some reason vulkaninfo now runs without issues and it shows both the nvidia and the built in intel card where it only did the nvidia card before. As far as i know i didn’t do anything. However the game still refuses to launch with dxvk on with the same “failed to create swap chain error”


#8

And now restarting lutris and running it from command line it suddenly decided to work. I’ll check my history if i’ve done anything but i’m baffled…


#9

So i purged vulkan-tools and purged any broken packages using sudo apt-get purge $(dpkg -l | grep ^rc | awk '{ print $2 }') reinstalled all my nvidia drivers and reinstalled vulkan packages. Even though i shouldn’t need it i also installed mesa-vulkan-drivers and then after that didn’t seem to work shut down my computer until the next day.

Then today i ran sudo vulkaninfo and it actually ran fine. Just in case i had added VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json to the environment variables just in case and the game ran with vulkan now…


#10

Turns out running sudo vulkaninfo seems to fix it for me, had issues again today and after running that it fixed itself.