[SOLVED] I messed my Starcraft 2 install (╯°□°)╯︵ ┻━┻)

Hello Lutris community!

My name is Baltazar and I have just manage to messed up my perfectly working Starcraft 2 install.

Am not sure as to the culprit but I fear it was the RetroArch that I tried to install along with the mupen64 core I wanted to use on my Kubuntu install… although there were a few updates I had today, which I don’t know if they are also part of the problem.

lutris -d: https://paste.ubuntu.com/p/D5PPN2HHRZ/

Log: https://paste.ubuntu.com/p/D38VVZQmz3/

Updates made to Kubuntu today (game worked last night fine): paste.ubuntu link /h4x3qZsS3m/

Installations of the possible culprit: paste.ubuntu link /JVCm5T6VM9/

I’m stumped… and wish it is something simple to fix… by the way, the damn Retroarch did not start after I installed the mupen64 core… after that I tried to run Starcraft only to find that the damned thing fails and give me the regular Blizzard error with “The application encountered an unexpected error” and its ID 74BDC685-2C78-4311-8DE4-C6BC8A3FC370, which I guess is of no help.

Anyways… this is just bad. I always look for what apps will try to do with certain files, like wine, though I have had no issues for over a year now.

(╯°Д°)╯︵/(.□ . ) (flips self)

Please help…

… looking at the lutris --submit-issue output: https://paste.ubuntu.com/p/TcPxQcBR2v/

I see that i386 libvulkan.so.1 missing…


Vulkan Instance Version: 1.1.70

/build/vulkan-UL09PJ/vulkan-1.1.70+dfsg1/demos/vulkaninfo.c:2700: failed with VK_ERROR_INITIALIZATION_FAILED

… so, I’m suppose to have that working right?

Would I need to reinstall Mesa? By the way, I have an AMD R9 280X…

… I have tried to reinstall vulkan as indicated at: https://github.com/lutris/lutris/wiki/Installing-drivers

and get the vokaninfo:

Vulkan Instance Version: 1.1.70

ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
/build/vulkan-UL09PJ/vulkan-1.1.70+dfsg1/demos/vulkaninfo.c:2700: failed with VK_ERROR_INITIALIZATION_FAILED

Battle.net at least tries to starts but I get: https://paste.ubuntu.com/p/fvNgB5mjN3/

I’m just reading the forum and stuff I find…

Do you have a 64-bit version installed? It appears to be trying to access the main driver library but discovers it’s 32-bit.

Also, for the sake of experiment, try running the game with Vulkan disabled (that’s DXVK option in Lutris if I’m not mistaken).

Log after disableling DXVK option in Lutris: https://paste.ubuntu.com/p/dy3NsKqNZt/

With the DXVK option in Lutris off Battle.net client runs, but the game wont start… some progress is good.

Also… the 386 versions no longer install because of broken pakages:

Doing :~$ sudo apt-get install --install-recommends winehq-stable wine-stable wine-stable-i386 wine-stable-amd64

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wine-stable-amd64 : Depends: libfaudio0 but it is not installable
wine-stable-i386:i386 : Depends: libfaudio0:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

Maybe it was the update of the system and not Retroarch…

The B-net client did manage to update so I tried to run Starcraft 1 which showed the splash screen and then the regular error window from B-net… I then tried Starcraft 2 a couple of time, but it would trigger the error window immediately.

I did the Lutris -d command: https://paste.ubuntu.com/p/7FWVtCGkZq/

Hope this helps with the diagnostic…

If libfaudio0 is missing, you can either add an older release repository to your package manager, or try to download and install the package manually.
Alternatively, you could try to make the game work without DXVK by installing DirectX of the version used by game (11?) via Winetricks. This isn’t really reversible (though you could set override of that library to builtin in Wine settings), so if it took a long time to set up the prefix, you may want to make a backup copy first.


I had read that entry about installing them missing libraries, but was not sure about it. I just follow your recommendation on it and was able to get the game up and running.

For clarity’s sake I will detail what I did for anyone else encountering this error about:

The following packages have unmet dependencies:
wine-stable-amd64 : Depends: libfaudio0 but it is not installable
wine-stable-i386:i386 : Depends: libfaudio0:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

I went and downloaded the packages from the link mentioned:


in the /amd64/ folder/link


and in the /i386/ folder/link


With this inside of the folder I saved them I did the equivalent cd ~/ to the directory and opened a Terminal, but through the GUI of the file manager by going into Control > Tools > Open Terminal while in the folder.

Here in the Terminal I did the required install command:

sudo dpkg -i libfaudio0_19.07-0~bionic_amd64.deb libfaudio0_19.07-0~bionic_i386.deb

and then the:

sudo apt --fix-broken install

With this ones completing successfully I was able to run:

sudo apt-get install --install-recommends winehq-stable wine-stable wine-stable-i386 wine-stable-amd64

(this is as a followup/continuation of the https://github.com/lutris/lutris/wiki/Wine-Dependencies (Ubuntu 18.04 since I am on Kubuntu 18.04)

Now, finally I was able to have this correctly Installed.

So I fired Lutris, Went to the Runner options and selected the WineHQ staging (5.5(Staging)) and set the DXVK back on (although I then noticed that it would get disabled, so it is not being used at the moment).

The game starts nicely… so I will now go and actually play the darn game and cool of a bit…

THANKS… thank you and others for helping! Lets see how it behaves now with the new Wine.

Only issue I have now is that there is a bit of lag with the graphics which forces me to lower them to High from Ultra… I guess the Vulkan issue or DXVK might play a part in that… but am able to play.

If there are any suggestions I will appreciate it.