[Solved] Heroes of the storm install hanging

I am having some issues getting HotS to install with Lutris.
I have installed all the dependencies as listed on the github repo https://github.com/lutris/lutris/wiki/Game:-Blizzard-App
As well as this I have followed the Arch steps for esync in regards to DefaultLimitNOFILE.
Clicked the install button as listed on the hots page here, ran through everything then battle.net loaded up after I clicked play. I click install and get stuck here https://imgur.com/a/eXYcMeO Have also tried deleting the stuff in ProgramData, but no success.

Edit: So it eventually installed, I cleared ProgramData a bunch of times.
I have ticked the use DXVK box, and said 0.64. Seems to be around 100FPS however it does spike down to around 60-70 at times, and can be a bit jittery when moving to the edge of the screen. Is this expected?

In my experience with HotS, you can make everything maximum, EXCEPT shaders. I keep shadow quality on low and every other toggleable option on high/ultra (except antialising because I like high framerates in action games)

When I’m playing the game, it has a huge impact when everybody shows their skills for the first time, but then it runs smoothly. That seems to be a running problem with Wine games.

Apparently having GLSL enabled reduces this problem, but only for NVidia gfx. Since I’m on AMD, I can’t confirm it. It should be enabled by default on your runner settings.

You can probably put DXVK 0.71 in the version number (manually type 0.71 and press save) and it shall download the newest version and put it to work. If it doesn’t either return it to 0.64 or update your graphics drivers.

Please change the topic to “[SOLVED]…” since the issue itself is alright.

I’ll fiddle with the settings. Until about last year the whole first spell thing used to be an issue on Windows as well.
Do you get much fps drops? The indicator on the top left, has a lot of red bars in it for me.

It only drops for me on the very first minutes of the battle. I usually pan my camera around the map to load the map, then I pan towards some initial action to load those as well.

One thing to note: ALWAYS close the battleNet client thing. People mentioned it increases stuttering (even on windows) and having that toggle “close battle net when playing” doesn’t work for that game, for some reason (works on the diablo 3 installer).

I simply press play and 3s later press on the (x) in the window.