Back to the main site

[SOLVED]Hat in time


#1

Just install hat in time from the steam wine installer. Game start, show the splash screen, but crash after a few seconds. Got this in the clipboard after the crash:

Fatal error!

Address = 0x1d6e1ca2 (filename not found) [in C:\windows\system32\XAudio2_7.dll]
Address = 0x1d6e237e (filename not found) [in C:\windows\system32\XAudio2_7.dll]
Address = 0x1d6a4a30 (filename not found) [in C:\windows\system32\XAudio2_7.dll]
Address = 0x1d69ff54 (filename not found) [in C:\windows\system32\XAudio2_7.dll]
Address = 0x1d697808 (filename not found) [in C:\windows\system32\XAudio2_7.dll]
Address = 0x1d69634a (filename not found) [in C:\windows\system32\XAudio2_7.dll]
Address = 0x4098891d (filename not found) [in Z:\home\simon\.local\share\lutris\runners\winesteam\prefix\drive_c\Program Files\Steam\steamapps\common\HatinTime\Binaries\Win64\HatinTimeGame.exe]
Address = 0x4098aa32 (filename not found) [in Z:\home\simon\.local\share\lutris\runners\winesteam\prefix\drive_c\Program Files\Steam\steamapps\common\HatinTime\Binaries\Win64\HatinTimeGame.exe]
Address = 0x4098bfb3 (filename not found) [in Z:\home\simon\.local\share\lutris\runners\winesteam\prefix\drive_c\Program Files\Steam\steamapps\common\HatinTime\Binaries\Win64\HatinTimeGame.exe]
Address = 0x40987e0c (filename not found) [in Z:\home\simon\.local\share\lutris\runners\winesteam\prefix\drive_c\Program Files\Steam\steamapps\common\HatinTime\Binaries\Win64\HatinTimeGame.exe]
Address = 0x403f1123 (filename not found) [in Z:\home\simon\.local\share\lutris\runners\winesteam\prefix\drive_c\Program Files\Steam\steamapps\common\HatinTime\Binaries\Win64\HatinTimeGame.exe]
Address = 0x409a8cb4 (filename not found) [in Z:\home\simon\.local\share\lutris\runners\winesteam\prefix\drive_c\Program Files\Steam\steamapps\common\HatinTime\Binaries\Win64\HatinTimeGame.exe]
Address = 0x409a8cb4 (filename not found) [in Z:\home\simon\.local\share\lutris\runners\winesteam\prefix\drive_c\Program Files\Steam\steamapps\common\HatinTime\Binaries\Win64\HatinTimeGame.exe]

What can I do?

Thanks


#2

In wine configuration, in the libraries tab, if I override XAudio2_7 and set it to builtin, than native, the game start correctly.


#3

I was going to suggest that, it seems like the installer needs to be updated