[SOLVED] Guild Wars 2 Bad EXE

I can’t get Guild Wars 2 to even launch. I’m on Mint 19 and I have installed wine-hq. I’ve downloaded the installer from the Lutris website and now I get this:

wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
wine: Bad EXE format for C:\Program Files\Guild Wars 2\Gw2-64.exe.

I know I can ignore the first line, but googling for the second wields nothing useful. It says I might be trying to run a 32 bit application with a 64 bit prefix or vice versa, but I have all 64 bit in the configs.

Right click the game on lutris menu>configure>game options. Is the executable correct? Try pressing on it to confirm if you can find Gw2-64.exe.

The installer was published a day ago, so either something changed by the time you tried, or the update slightly broke the installer.

1 Like

Yes, the executable is correct. I’ll try with the new installer and report back.

Okay, tried with the new one, same mistake. I looked again to see if I was seeing things with the executable and it’s apparently 0 bytes? :expressionless:

Looks like they removed/moved it https://s3.amazonaws.com/gw2cdn/client/branches/Gw2-64.exe

Please try the updated installer.


The new installer seems to be working! The game is actually launching and downloading itself now. Thank you!

how did you fix this?

Hello lunakyle, welcome to the Lutris forums!

To fix the error I used the installer linked by cxf: https://s3.amazonaws.com/gw2cdn/client/branches/Gw2-64.exe

Just replace it in the folder that Lutris points to.

Since it’s been 4 years, I am not sure if the solution remains the same, but it’s probably a good idea to try it.

If it doesn’t work, I recommend using ArmoredVehicle’s package instead, which you can find here: Playing Guild Wars 2 on Linux - Performance optimizations and more. - Account & Technical Support - Guild Wars 2 Forums