Back to the main site

[SOLVED] GTA V poor performance (10-20FPS) [Manjaro]


#1

Hi everyone,

I get a really choppy framerate running GTA V. I’m on

██████████████████  ████████   user@7HEPC 
██████████████████  ████████   ------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Kernel: 4.14.71-1-MANJARO 
████████            ████████   Uptime: 1 hour, 17 mins 
████████  ████████  ████████   Packages: 1657 (pacman) 
████████  ████████  ████████   Shell: bash 4.4.23 
████████  ████████  ████████   Resolution: 1920x1080, 1920x1080 
████████  ████████  ████████   DE: Xfce 
████████  ████████  ████████   Theme: Matcha-dark-azul [GTK2], Arc-Dark-Grey [GTK3] 
████████  ████████  ████████   Icons: Papirus-Adapta-Nokto [GTK2], Numix-Circle [GTK3] 
████████  ████████  ████████   Terminal: tilix 
████████  ████████  ████████   CPU: Intel i7-6700 (8) @ 4.000GHz 
████████  ████████  ████████   GPU: NVIDIA GeForce GTX 1050 Ti 
                               Memory: 2801MiB / 32110MiB 

+Compton compositor.

Here’s a logfile: https://paste.ubuntu.com/p/gNK8J8mWqF/
Obviously there’s something wrong with the keyboard layout. Setting it to the US layout in the game’s settings had no impact whatsoever.

I used the Steam /w DXVK install script found here: https://lutris.net/games/install/8251/view

Game installed fine in Wine Steam but performance was extremely poor from the beginnning. Things I tried were:

  • Switching Wine from esync-staging-pba-3.16-x86_64 to 3.15 staging in my system. Tried regular Wine 3.15 too. Also following instructions to enable esync for systemd and confirming it’s applied.
  • Switching DXVK on/off. Current version installed 0.80.
  • Switching DX10/11 in the ingame settings and through commandline arguments.
  • Followed WineDB intructions to enable CSMT and EAX
  • Turning off compositor (as suggested by cxf)

Peaking at htop all CPU cores are at round 40-60% load nicely spread out and the GPU load is somewhere between 10-20% according to nvidia-settings while ingame on “normal” settings, no taxing effects etc.

Am I missing something? :smiley:

Solution as pointed out by DrCrocktagon013563 works. Follow the steps here:


Works in both Wine Steam runner and Steam Play.


#2

Turn off your compositor?


#3

That made no difference unfortunately…


#4

If you haven’t already, try what’s suggested here.

You can also create a file called “dxvk.conf” with the same contents, and put it into the same directory as the game exe for the same effect.


#5

Yes! That worked. Been already running it with the Wine Steam runner and also with Steam Play in the native client that way for almost all day. Thanks for pointing me there! :slight_smile: