[solved] GTA V installation problem with MS Visual c++ 2008

Hi, I’ve been cleaning my PC to install GTA and apparently I broke something. When I’m trying to install GTA V wine DXVK version I get error “install ms visual c++ 2008” after installing rockstar launcher. I’ve install winetricks with no luck and ms visual c++ straight from microsoft’s web page. I don’t know how can I fix it.

This isn’t a Wine error, it’s a Python error (it happens within Lutris itself). It says that the Lutris Wine module doesn’t have a member (function) called install MS Visual c++ 2008… Which it certainly doesn’t, at the very least because whitespaces and arithmetic symbols can’t be a part of function name in Python.

Are you using this install script? I’m not a guru of Lutris install scripts but I suspect it’s borked, because name of a task in it contains some arbitrary string (more specifically the one you got in that error) but just by looking at other tasks I can tell it has to contain a keyword (the name of the function that Lutris needs to run for this task, I believe). If you need to use this particular install script (i.e. you don’t have this game in Steam), you can try to fix it (next to the Install button, open the menu and choose Edit option, then write down the reason).

I suspect you need to either change name in that task to wineexec (to run a Windows executable) or change name to winetricks and replace executable and arch entries with app: vcrun2008 (as Winetricks is what you normally use to install libraries like Visual C++ runtime). If the latter works out, you may want to also remove MSVcpp2008 from the files section.
And yes, to run the script, you need to save it (“Save draft”) and then run it (“Test this installer”). If after saving you’re redirected to the game page, click “Show unpublished installers” to look for your draft – it should be marked with something like “last published 1 minite ago” as you just saved it.

…It might also be that the install script was messed up recently, because it shows there’s several draft versions but when trying to switch to a different one edit page seems to bug out and load the latest one.

If you really don’t want to edit text for some reason and willing to wait, I guess you could try to report an issue with the script instead (or maybe it’s the server that’s broken and giving you a wrong file version?), from the same menu.

1 Like

Thank you for your answer. I’d like to learn a little bit about what exactly what should I change to what and have a little bit of time to mess around with that script, but I’ll have to wait untill the weekend to have some time to wrap my head around this. If this script will be fixed by then, then it’ll be cherry. Also I’ve seen that yesterday some folks had same issue [https://lutris.net/games/grand-theft-auto-v/]. I just scrolled down and saw 2 comments from 1 day ago.
Thank you again and take care @LeXofLeviafan.

It works now. It was script’s fault.