[SOLVED] Gstreamer errors, missing plugins

Hello, what does these logs mean? My games were working fine until an update broke them all

[Solution below, first comment]

Started initial process 459891 from /home/caferino/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/bin/wine /home/caferino/disk/Games/TheSims4/The Sims 4/Game/Bin/TS4_x64.exe --exec=launch Pro -alwaysoffline
Start monitoring process.
fsync: up and running.

(wine:459977): GStreamer-WARNING **: 03:39:30.172: Failed to load plugin ‘/home/caferino/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib64/gstreamer-1.0/libgstjpeg.so’: libjpeg.so.62: cannot open shared object file: No such file or directory

(wine:459977): GStreamer-WARNING **: 03:39:31.094: Failed to load plugin ‘/home/caferino/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib64/gstreamer-1.0/libgsthls.so’: libnettle.so.6: cannot open shared object file: No such file or directory

(wine:460064): GStreamer-WARNING **: 03:39:57.931: Failed to load plugin ‘/home/caferino/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib/gstreamer-1.0/libgstdtls.so’: libcrypto.so.1.1: cannot open shared object file: No such file or directory…

… they are like a 100 of the same gstreamer thing.

(wine:460064): GStreamer-WARNING **: 03:39:58.065: Failed to load plugin ‘/home/caferino/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib/gstreamer-1.0/libgstlibav.so’: libavfilter.so.7: cannot open shared object file: No such file or directory
wine: configuration in L"/home/caferino/disk/Games/TheSims4/Game/the-sims-4" has been updated.
Parsing Z:\home\caferino\disk\Games\TheSims4\The Sims 4\Game\Bin\anadius.cfg.
Detouring transaction succeeded
fake key created
replacing Client Path
LSX emu online module version 1.3.0.0
online dll found!
always offline
authentication failed, starting offline
fake key created
replacing Client Path
game connected
profile name: Caferino
profile name: Caferino
wine: Unhandled exception 0x20474343 in thread 140 at address 000000007B0124DE (thread 0140), starting debugger…
Process of pid=013c has terminated
No process loaded, cannot execute ‘echo Modules:’
Cannot get info on module while no process is loaded
No process loaded, cannot execute ‘echo Threads:’
process tid prio (all id:s are in hex)
00000038 services.exe
[“C:\windows\system32\services.exe”]
0000003c 0
00000040 0
0000004c 0
0000005c 0
00000070 0
0000007c 0
00000094 0
000000ac 0
000000e0 0
00000044 winedevice.exe
[C:\windows\system32\winedevice.exe]
00000048 0
00000054 0
00000058 0
00000060 0
00000064 0
000000b8 0
00000068 winedevice.exe
[C:\windows\system32\winedevice.exe]
0000006c 0
00000074 0
00000078 0
00000080 0
00000084 0
00000088 0
0000008c plugplay.exe
[C:\windows\system32\plugplay.exe]
00000090 0
00000098 0
0000009c 0
000000a0 0
000001b4 0
000000a4 svchost.exe
[C:\windows\system32\svchost.exe -k LocalServiceNetworkRestricted]
000000a8 0
000000b0 0
000000b4 0
000000bc tabtip.exe
[“C:\windows\system32\tabtip.exe”]
000000c0 0
00000100 0
0000010c 0
000000c4 explorer.exe
[C:\windows\system32\explorer.exe /desktop]
000000c8 0
000000cc 0
000000d0 0
000000d8 rpcss.exe
[C:\windows\system32\rpcss.exe]
000000dc 0
000000e8 0
000000ec 0
000000f0 0
000000f4 0
000000f8 0
winedbg: Internal crash at 000000014001E73A
Initial process has exited (return code: 17152)
Monitored process exited.
Exit with return code 17152

1 Like

SOLVED.

The solution was weird, but I feel lucky.
First, I checked the terminal for updates, using the command apt update, but everything was up to date. However, I had the weird idea to reinstall wine, thinking that maybe those gstream missing plugins belonged to it. In the middle of the installation, right when it asked me to do the sudo apt update again, after getting some keys, it returned 5 upgradable apps. I upgraded them, then I received another 8 updates regarding other stuff, and finally, I checked my graphics card because these updates tend to switch my laptop’s GPU to Integrated instead of Hybrid, or Nvidia as I like it. It did, it was on Integrated instead of Nvidia, so I just switched it back (had to try twice, some daemon error happened at first, I just ignored it), rebooted the laptop and that’s it, my game worked.

1 Like