[SOLVED] Grand Theft Auto IV: No audio

I bought Grand Theft Auto IV from the rockstar launcher and used the Wine script install by searching the game with lutris
The launcher installs and i am able to install the game but when the game launches there is no audio everything else seems to be working

Do you get sound in other games, or is it just GTA IV that has no sound?

just to check some basics… is the sound output set to the audio device you want to use before launching the game?

but it appears you are using “lutris-GE-Proton8-13-x86_64” which these variations are what I use for the vast majority of games I play through Lutris (I am using v0.5.12 since there are show-stopper regressions on two games I play on the newest v0.5.13).

I am running Mint 21.2-Xfce and I don’t have any issues in regards to sound on my games in general (I have not tried your specific game though). I am using one of those cheap USB sound cards (since my motherboards on-board audio died a few years ago) with a 3.5mm jack and Mint Xfce see’s it as ‘Audio Adapter ‘Unitek Y-247A’ Analog Stereo’ in the ‘Sound’ icon section.

what does the following show on your system…

inxi -A

mine shows as…

  Device-1: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
  Device-2: C-Media Audio Adapter (Unitek Y-247A) type: USB
    driver: cmedia_hs100b,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.15.0-78-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes

p.s. you may be interested in (I am assuming you got the ‘Grand Theft Auto: Complete Edition’)… GitHub - ThirteenAG/GTAIV.EFLC.FusionFix: This project aims to fix or address some issues in Grand Theft Auto IV Complete Edition ; that general ‘ThirteenAG’ place has a lot of fixes for older games in general which usually boils down to widescreen fixes to make many older games from say the 2000’s display properly on modern resolutions like 1080p etc. but to use that fix for GTA IV you got to enable ‘dinput8.dll’ in Wine configuration as Linux does not use those by default like Windows does.

1 Like

this is the only game giving me audio issues at the moment
Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
driver: snd_hda_intel
Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
Device-3: Logic3 Afterglow Universal Wireless Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.15.0-79-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes

I was given this tip by another Linux gamer and it has solved my issue