[SOLVED] Gecko Installation Fails Linux Mint

Hey all, I’m brand new to Lutris and having some issues getting WineSteam to open up. I’m running on Linux Mint 18.3 (ubuntu 16.04). Steam appears to have installed fine, as in it open to the login, but as soon as that happens some screens flash that I can’t make out and it crashes.

I think this traces back to my Gecko install which seems to be failing. When trying to install the game in question it keeps getting stuck on “Installing Gecko” and simply displays a tiny white rectangle in my screen. I tried just doing apt install wine-gecko but Lutris doesn’t seem to find that package. How can I manually reinstall Gecko since it appears that it just keep failing if I install the runner?

Decided to try to download the installer script locally and run it using the CLI option lutris -i file.json and this provided me with the errors thrown after the steam login fails and crashes.
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197960265728 [API loaded no] [0731/120326.228:INFO:crash_reporting.cc(215)] Crash reporting enabled for process: renderer [0731/120326.652:ERROR:gpu_process_transport_factory.cc(1029)] Lost UI shared context. [0731/120326.732:ERROR:process_snapshot_win.cc(293)] unexpected unloaded module list element size [0731/120326.817:ERROR:broker_win.cc(57)] Error reading broker pipe: Broken pipe. (0x6D) [0731/120326.818:ERROR:cmd_buffer_helper.cc(139)] ContextResult::kFatalFailure: CommandBufferHelper::AllocateRingBuffer() failed [0731/120326.821:INFO:crash_reporting.cc(215)] Crash reporting enabled for process: renderer [0731/120326.825:ERROR:broker_win.cc(57)] Error reading broker pipe: Broken pipe. (0x6D)

I suggest deleting all files you currently have from lutris and wine in your system, then downloading winehq-staging from their official page: https://wiki.winehq.org/Ubuntu

After that, making sure all recommendations are done, install lutris from their recommendations and from “apt install lutris”. There’s no need to rebuild it or use other workarounds.

Afterwards, try installing winesteam and running it or installing a simple wine game to test functionality.

I’ve used Lutris in Linux Mint 18.3 and 19 Cinnamon and everything was alright. I installed Gecko and Mono when Wine prompted it. I had a few problems running in the MATE environment, but I blame that on the install script for a specific game.

This worked well. Thanks. This installation does seem out of place however, as Winehq has 3.13 in staging at the moment, whereas installing winesteam used the 3.12 version anyways. The installation did work however, so not going to question it.

Wine versions may change, but their dependencies may stay the same.

Wine 3.0 may use the same package for graphical interface as 3.13 uses, for example. There’s no problem with that.

Please change your title with the name [SOLVED] before it, to flag for other users. Cheers!