[SOLVED] Game only runs from the ubi launcher, or from "Run Exe inside Wine Prefix"


This is a brand new Steam Deck, lutris has just been configured to run several launchers, which it does successfully + 3 games from different launchers.

I have successfully installed the Ubisoft Connect launcher in lutris, from lutris script. It seems to be working fine.

Then I installed Immortals Fenyx Rising from Lutris script as well. When triggered it launched the ubisoft launcher, I installed the game from the launcher and closed ubisoft connect.

If I:

  • launch ubisoft connect from lutris
  • launch the game from inside the ubisoft launcher then the game works like a charm

If I select the game in lutris, then click on “play” it launches the ubisoft connect initialization popup and freezes for ever.

If I select the game in lutris, then click on "Run Exe inside Wine Prefix’, select the game exe then it starts (I don’t see the ubisoft initialization popup though, which makes me think it may work differently :o).

I’m new to this, so I’m probably missing something obvious but I literally spent 8 hours to try to get this to work:

  • tested dozens of lutris wine versions, or proton-ge versions
  • tested to add various arguments
  • tested to add components, even if noone suggested this on protondb.com
  • checked the logs from lutris, most of the time there are no errors, then when I force stop ubisoft connect I can see error such as “Bad File Descriptor”
    Also, I’ve seen errors related to the script not bein able to access to gstreamer .so, but they are all there. In any case I havn’t seen these errors for a while. Maybe it was when I was using to old proton binaries.
    I found quite some info about both, but none help.
  • tried to modify the paths in the game conf in lutris/in the steam interface
  • etc

Any idea of what could explain why it works from ubisoft connect directly, and not from lutris/steam directly? Or how can I get it to run as if I was running it from "Run Exe inside Wine Prefix’?

I havn’t tested to install another game from the ubisoft launcher yet.


1 Like

I just realized that when i trigger the installation through lutris it states that “Ubisoft will now open and install Immortals Fenyx Rising”, yet it launches Ubisoft but doesn’t install it by itself, I had to install it manually from ubisoft connect. Maybe that it’s an important detail? I checked the install script and it doesn’t seem like it’s capable of installing it by itself though… But I’m no specialist…

1 Like

Just tried with AC Valhalla and am experiencing the exact same issue…

1 Like


  • i uninstalled the ubisoft launcher and Immortals Fenyx Rising
  • reinstalled the ubisoft launcher
  • instead of triggering the install from the ubisoft connect menu in lutris, I searched for the Immortals Fenyx Rising in the app’s search bar, then installed. And it worked out of the box.

There’s clearly a difference:

  • when I run the installer from the ubisoft connect menu section it didn’t trigger the game installation directly: it launched ubisoft connect and did nothing more. I had then installed the game from the launcher manually
  • when I ran it “from the search results” it actually really triggered the game install directly. I did not have to go through any other steps than the regular game installer steps (set the path etc).

You also might need to change the launcher configuration where if you use the Lutris install script it has the launcher id in Guid format change it to the official launcher id of the game

I got some of the ID from the link above