Back to the main site

[Solved] Frostpunk - crashing after some time


#1

Hello,
during the installation of Frostpunk (gog/dxvk version) some errors appeared (caption error stub with ok button) - right at the end of the installation - when directx started to install.
Game itself crashes after about couple ingame days, cant really say what causes crash.
Also i cant change video settings to windowed borderless - because game wont be able to capture keyboard (it wont work).

Logs from installation process:
https://paste.ubuntu.com/p/3F3jM4QP5n/
Logs from gameplay:
https://paste.ubuntu.com/p/PSW88xk5kG/
System:
https://paste.ubuntu.com/p/q2jdjK3C2S/


#2
eventfd: Too many open files

Esync problem. Remove it from environment variables. Enable “Show advanced options” on the bottom left if it’s not showing up.

Also update your drivers (to at least 396.54.09) and use DXVK 0.93.

sudo add-apt-repository ppa:graphics-drivers/dev
sudo apt update
sudo apt install nvidia-driver-396

You can get 410/415 drivers from ppa:graphics-drivers/ppa but afaik 396 is still better for DXVK.


#3

Done, game still crashes but its noticeably faster.
Game slow downs a lot (10-15fps from 60) on windowed borderless setting.

Log:
https://paste.ubuntu.com/p/hnCrrz2swf/


#4

A Wine log would be more revealing than dxvk’s. https://github.com/lutris/lutris/wiki/Getting-Help:-Providing-logs-&-System-Info


#5

I have deleted frostpunk install along with local files and installed again updated version (which contained your fixes). Game is not crashing anymore but there are sometimes drop on fps from 60 to 30-15fps.
Log:
https://paste.ubuntu.com/p/W4jVCnQGZW/

EDIT:
why my previous posts are hidden? There wasnt any explanation why they got hidden…


#6

And one more log where i crashed game by alttabbing (from fullscreen mode), couldnt alttab back to game because it crashed.
https://paste.ubuntu.com/p/jcP6skDG39/


#7

Bot flagged it for spam.

Might be due to Wine log spam or disabling Esync but hey at least it’s not crashing anymore.

err:   DxvkSwapchain: Failed to recreate swap chain

Alt-tabbing might be a problem. I think that means it failed to recreate the window or something. Try enabling virtual desktop if you want to alt-tab.


#8

Its either i cant alttab out of game or it crashes when alttabbing.
Aside of that issue is solved