The FFXIV launcher works fine, but by the time I try to launch the game I get stuck with this error: A fatal DirectX error has occurred. (10000000)

I followed the guides I found through Lutris to update my nvidia drivers, install wine, and grab the necessary vulkan drivers. The following pastebin includes both the “lutris --submit-issue” and debug output.


Now, for some reason, the ffxiv launcher on the 4.10 runners lets me login but not click any of the buttons. It… wasn’t doing this before so I’m not certain what changed. With a 4.11 runner I just get the standard ~“DirectX not detected” error.

edit: The wine configuration tool is showing up black, so I’m going to make the safe bet that this particular problem is just wine related.

I think any DirectX error is related to how Wine+DXVK interact. Experiment playing with DXVK off (should either NOT work or be horrible). There may be an issue with using dx9 mode instead of dx11 mode, which is what you want to use for DXVK, but I don’t own FFXIV to know how would someone set the DX version to run the game.

Then, can you remember your last settings? If it worked before, either you’re having some driver issues or your Wine has become incompatible with DXVK in some way.

The last thing I’d look would be integrated/dedicated GPU confusion. If you can play any other game using vulkan/dxvk, we can rule out that problem. (You can try Warframe, Path of Exile and DotA 2 [native vulkan] to experiment on that )

i got ge-protonified-4.10 working again and it least lets me get ingame w/ dx9

i’ll have to try installing dota 2 and see if it works

i’m dumb i just needed to set VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json which the common issues page even mentions

1 Like

Change your topic as [SOLVED] so other users can know it. Also, I swear I read the common issues wiki to get back to you, but apparently I oversaw that part. Good catch ^^!

1 Like