Back to the main site

[Solved]Endless Legend Loading screen crash


#1

Hey guys , installed endless legend , lutris installer works perfectly , i enter the main menu , i go and create a new game ( or enter tutorial ) and the game has to generate a map. While in loading screen i get a error : WorlGenerator.xml failed and i’m stuck at the loading screen. tried to go with wine 2.18 since it was the last working version but it s the same thing.


#2

Hey there,

Can u checked Game Settings that is set to 32bit ?

Also in Wine settings set it to Windows 7 or higher then it should work ;).

Have a nice day :).


#3

Thx for the help , it was win7 tried the 32 bit version and 64 bit version changed it from lutris and steam as well to make sure but it still doesn t work :frowning: thx anyway


#4

Hey,

Tried higher Windows settings in Wine (8.1 should work but maybe 10 to).

Also use the last Wine version on 32 bit & let me know if it fix your issue. :slight_smile:

Happy Eve :smile:


#5

Try disabling winegstreamer via winecfg dll overrides - this helped with a similar issue with Endless Space 2 for me.


#6

can u elaborate please ? newbie here :frowning:


#7

https://i.imgur.com/KK0YrD2.png -> did u mean this ? it didn’t work … :frowning:


#8

I did a quick peek and it seems you’re right and this won’t help with your problem. Better remove that entry again to avoid it having any undesirable side-effects.

According to WineHQ.org the game should be working with 2.18 staging

I just did a quick test and can verify that it does hang on map generation with wine staging-2.21-x86_64 and that it does start into the game with staging-2.18-x86_64. So your best hope for now is downloading wine staging-2.18 and configuring Wine Steam to use it.

You might need to reinstall your Wine Steam into a 64 Bit prefix first as Lutris seemingly no longer provides wine staging-2.18-i386 through the “manage wine versions”-menu.

I’ll try to add a second Endless Legend Installer that uses a 64 Bit wine steam prefix and the mentioned wine version. Once the change is though moderation Lutris should once again be able to install the game in a working manner.


#9

oh shit man thx , it works with stageing 2.18 64 bits and windows 10 it loads , BUT i do get a crash while in-game ( mscorsw.exe) if u have any ideea for that let me know. Again thx alot @DaDummy and @LCF !


#10

mscorsw.exe is related to .NET which does not work on 64-bit Wine versions/prefixes.


#11

@cxf lmao waste 1 hr to check that and forgot to check lutris forums XD thx man


#12

Well after reinstalling it , 2.18 32-bit windows 10 works fine ! Guys thank you all for your help !


#13

Glad to here that, dont forget to put ur post on solved & have nice gaming sessions on linux :wink: .