[SOLVED] DXVK on Path of Exile (Invalid Vector <T> error)

I’ve read a lot about Path of Exile support.It all breaks down to this guy’s comment:

You need two specific patches on your Wine to have it

  • Pass WIC Factory Error
  • Pass Fonts error

I didn’t use ge-wine3.6 because it doesn’t support the newest DXVK releases.
A user has reported being able to play the game with esync-fo3.14 and DXVK 0.65, but that yields the the Fonts errors on my side.

I’ve managed to compile my own wine64 with the correct patches to initialize the game and it does run on DX11 with DXVK disabled. When I enable DXVK, the Invalid Vector subscript error appears.

I suspect my mesa drivers are not right, although they’re “bleeding edge”.

My graphics card is the Ryzen 5 2400G apu and mesa:

glxinfo | grep “OpenGL version”
OpenGL version string: 4.4 (Compatibility Profile) Mesa 18.3.0-devel - padoka PPA

Can anybody with an AMD GPU confirm that my mesa drivers are “too updated” to support some DXVK features? I don’t want to go through downgrading to the recommended driver (18.1.3 or newer) and have it still not work.

DLL overrides:

riched20 (n,b)
usp10 (n,b)
d3dcompiler_47 (n)
xaudio2_7 (n,b)

Env. Vars. DXVK_HUD=fps

I copied wine-mirror for wine 3.15, applied staging patches and then applied Path of Exile CoInitialize patch, built it using the biarch tutorial and then compiled DXVK with this newly built wine-staging.

The game now works with the newest DXVK 0.71.