[Solved] DXVK/Lutris broken after GPU change

After I changed to a vega 64 from a GTX 980 ti lutris, or rather the games in it stopped working.Of course I purged all Nvidia drivers and autoremoved anything else.I cannot fathom wherein the problem lies… I followed anything here(https://linuxconfig.org/improve-your-wine-gaming-on-linux-with-dxvk) first when I had the 980 ti and now for the Vega 64.

I just recently started using Ubuntu (trying to migrate from Windows, for that everything has to work, which I use on a daily basis) so I may or may not understand some things.

Here a picture of FFXIV(one of the sole games I use(d) on lutris): https://imgur.com/zRxMMf5

Guild Wars 2 makes my complete system freeze, when opened.

Thanks in advance!

Solved it by uninstalling AMDGPU(pro) drivers and installing MESA!

What does glxinfo yield?

Here is what I have showing an NVIDIA setup.

[andrew@schotty-tower-wired applications]$ glxinfo | grep vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
[andrew@schotty-tower-wired applications]$

Not sure if this will help but at least on manjaro installing drivers is not enough, there’s also vulkan related packages for intel/nvidia/amd so maybe you should check if you have those installed.
Maybe read this too. https://linuxconfig.org/install-and-test-vulkan-on-linux

Thanks, but solved it! :slight_smile: