Back to the main site

[Solved] DXVK Internal Graphics Card


#1

Hi,

I will start with a quick summary of what I wanted to do and what I think is my question:

  • I wanted to play some starcraft 2.
  • I got lutris from the download page and it installed just fine (though when I run lutris -v I dont get any output).
  • I got to the lutris page for starcraft 2. In the description it said I should check https://github.com/lutris/lutris/wiki/Game:-Blizzard-App first, so I did.
  • From there I got send to https://github.com/lutris/lutris/wiki/How-to:-DXVK. Here I found some instructions for Nvidia and AMD Graphics cards, but since I only have an internal Intel graphics card I was confused and skipped everything on said wiki page!
  • I nevertheless tried to run the install script and ended up with the “We’re having trouble launching the Blizzard Update Agent”-Error mentioned in the FAQ of the Battlenet-App wiki entry.
  • I also tried to run the BattleNet-App Standalone install script and got the same error.

I will update any information about my system here:

  • cpu: Intel® Core™ i5-7200U
  • os: Ubuntu 18.04
  • output of wine --version: wine-3.0 (Ubuntu 3.0-1ubuntu1)
  • output of glxinfo | grep "OpenGL version": OpenGL version string: 3.0 Mesa 18.0.5

Any help appreciated!


#2

So I don’t have a lot of experience with the Intel iGPUs, but the issue seems to be that your display driver isn’t a high enough version.

Can you see if "$ glxinfo | grep “OpenGL version” returns anything? It should post what OpenGL driver you have, and what version of Mesa you’re using. DXVK requires MESA 18.2, so if it’s anything less than that you’ll have to update. From what I understand updating Mesa is a small matter of adding the repo and updating using apt. There’s guides online but since I’m not experienced with your system, I’m hesitant to offer any advice.


#3

Not 100% sure but the AMD instructions also apply to Intel. Skylake is the minimum requirement so you’re good.


#4

Thank you both!
I updated my system information and it turns out, that I have only Mesa 18.0.5. So I guess I would have to update.
I guess I should do that before following the instructions for AMD according to the answer of @cxf?

I do not quite understand how Mesa and DXVK are related.

@cxf did the wiki page change since I asked my quetion? Now it says “AMD/Intel”, which I didn’t saw before.


#5

Yeah I changed it. Did it not work?


#6

DXVK works on Intel Haswell in Unity Engine games, some old games with dgvoodoo2 and recently the Watch Dogs worked as well.


#7

Ok. I followed the instructions on https://github.com/lutris/lutris/wiki/How-to:-DXVK and now the output of glxinfo | grep "OpenGL version" is OpenGL version string: 3.0 Mesa 18.3.0 - padoka PPA. Sadly I still get the same error from the Battle.net installer.


#8

Could you run the installer through the terminal? lutris -d starcraft-ii Make sure Lutris is closed first before running that and post the full log here.


#9

I do not know why, but this time it just worked. Maybe I forgot to update/upgrade after the last installations, since in between the two test the Ubuntu system updater popped up.

I am downloading the game now within the bnet-app.
Thank you all for your help!

(Can I mark the topic as “solved”, somehow?)