[SOLVED] Diablo 4 installer missing dependency: blizzard-battlenet-standard

Trying to install Diablo 4. Installer selection screen provides only one install option (wine). I select it and click “Install”, and get the following error popup:

Missing dependency: This game requires blizzard-battlenet-standard. Do you want to install it?

I click “yes” but nothing happens, it just loops back to the Installer selection screen. Clicking “Install” results in the same error popup.

Same error when installing from Lutris desktop app or from website installer.

I have both WoW and Diablo 3 installed, both work fine with no problems. I first tried installing Diablo 4 in the same BattleNet instance, but it crashes during launch. Now I’m trying to install it separately in its own BattleNet instance so I can try it with different Wine settings, but without breaking WoW or D3. That’s when this problem occurs.

lutris --submit-issue output: Ubuntu Pastebin

lutris -d output: Ubuntu Pastebin

Screenshot of error:

1 Like

I suggest you stick to existing BattleNet installation. You can have D3 and D4 in one Lutris profile, no problem.
D4 which you successfully installed in existing BattleNet profile, is a step ahead already, compared to what you are reporting.
To fix D4, you need specific version of Wine runner and VKD3D selected in this Lutris profile.
Details here:

1 Like

Thanks, I changed the working installation profile to lutris-GE-Proton8-5-x86_64 and VKD3D 2.8 and that solved this problem. D4 starts now, though there’s some instability and it crashes frequently. I’ll submit those in a separate issue later.

Excellent. That’s definitely a step forward.
I also got 8.7 to work, it does not crash BattleNet app anymore, so I can start D4 :slight_smile: All working ok for me, no crashes once it’s launched.


Can someone ELI5 what this means. All I know about Lutris is that I click install for SC2 and Overwatch, and they then work. I know nothing about Lutris beyond there is an install button, and then a game icon.

I have now run into this problem for Diablo IV, and I don’t know how to select and installation profile, the installation button gives no options.

@Deepstonk After you install the game, select it in Lutris, click the up arrow right beside the “Play” button, and in the popup menu select “Configure” (image 1). In the Configure dialog box that pops up, click the “Advanced” tab, click the switch at the top right to turn on Advanced Options (image 2). Then make the changes explained in the threads above there.

Hi all,

I performed fresh install, wine-ge-8-26-x86_64, battlenet install correctly, but D4 still not launching, it’s still requires VKD3D version 2.8. Anything beyond 2.8 is not launching the game.