Back to the main site

SOLVED: Deus Ex GOG installation and play problems


#1

Hello, I’m a Linux user of a few years but not technically versed. I’m trying to run Deus Ex, GOG version, but two problems come up.

If I try the install script within Lutris for GOG, it never asks for the .exe on my hard drive. It instead downloads a 400MB file from the GOG servers, which doesn’t install properly; all that shows up inside the install directory is a Deus Ex.ini. Image here. I tried downloading it in my browser and it looks like it’s an exposed copy of the Deus Ex install file on the GOG servers… Don’t think that’s supposed to happen?

I instead used my GOG install exe on my Windows 7 machine and copied the whole thing over into the wine instance. That earned me this error output in terminal.
I tried with 1.9.20 which was as close as I could get to AppDB recommendations, with WineHQ Staging 4.3, and with tkg-4.0_86_64, and I haven’t been able to make the game exe run.

I’m running Linux Mint 19.1 64-bit. Anything else I should post to look into this?


#2

There’s no error there. Do this and launch it again: https://github.com/lutris/lutris/wiki/Getting-Help:-Providing-logs-&-System-Info#debugging-output-for-a-game

Also you don’t need DXVK enabled since it doesn’t support DX10/11.


#3

I enabled the log and disabled DXVK. I tried running Deus Ex again through Lutris, and it downloaded a new mono configuration. After that it gave this this log output and then hung indefinitely. I waited about 10 minutes and nothing occurred. I closed Lutris completely and tried again, and the log only shows this upon retrying:

000b:fixme:winediag:start_process Wine Staging 4.3 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
0009:fixme:process:GetProcessWorkingSetSizeEx (0xffffffff,0x32f384,0x32f37c,(nil)): stub

EDIT: Running without the log makes it work now. Thank you for your help.