Back to the main site

[SOLVED] Cyberpunk 2077 crashes regularly

Hello everybody,

I bought Cyberpunk 2077 and install it with script on Lutris (app, not website) (GOG version, without Galaxy).
But I can’t do a full game without a crash : image don’t move, sound can be played but I don’t have controls.

And if wait too long, I can’t return to desktop or whatever, I must restart computer.

If you have an idea …

Thanks

System :

  • OS : Kubuntu 18.04.6
  • Kernel : Linux 5.5.2-050502-generic x86_64
  • Lutris : 0.5.9.1
  • graphic card : AMD Radeon RX 5500 XT
  • processor : AMD Ryzen 5 2600X Six-Core Processor - 3600MHz
  • RAM : 16GiB

For the game :

  • wine version : lutris-fshack-6.21-5-x86_64
  • DXVK : v1.9.2L-3e64e1b
  • VKD3D : v2.5L-db89d40
  • D3D extra : v2
  • DXVK NVAPI : v0.5-e23d450
1 Like

I think you need to download and use any one higher than version 6.12 GloriousEggroll (GE) version of wine. As there was a crash fix to Cyberpunk some versions ago. Just not sure if related to your issue though.

You do this from the wine preference in Lutris.

I have lutris-ge-lol-6.16-4 and lutris-ge-6.16-1.

I will try with this versions.

I try this two versions (lutris-ge-6.16-1_x86_64 and lutris-ge-lol-6.16-4-x86_64) and game has crashed.

Here’s what’s common in the logs I retrieved (lutris -d, in terminal) :

0104:fixme:d3d12_swapchain_resize_buffers: Ignoring flags 0x840.
0104:fixme:d3d12_swapchain_SetHDRMetaData: iface 000000007e500050, type 0, size 0, metadata 0000000000000000 semi-stub!0104:fixme:d3d12_swapchain_SetColorSpace1: iface 000000007e500050, colour_space 0 semi-stub!
info:  Game: Cyberpunk2077.exe
info:  DXVK: v1.9.2-21-g2e66f45a
info:  Built-in extension providers:
info:    Win32 WSI
info:    OpenVR
info:    OpenXR
info:  OpenVR: could not open registry key, status 2
info:  OpenVR: Failed to locate module
info:  Enabled instance extensions:
info:    VK_KHR_get_surface_capabilities2
info:    VK_KHR_surface
info:    VK_KHR_win32_surface
warn:  Skipping CPU adapter: llvmpipe (LLVM 13.0.0, 256 bits)
info:  AMD RADV NAVI14:
info:    Driver: 21.3.2
info:    Vulkan: 1.2.195
info:    Memory Heap[0]: 
info:      Size: 7936 MiB
info:      Flags: 0x1
info:      Memory Type[0]: Property Flags = 0x1
info:      Memory Type[4]: Property Flags = 0xc1
info:    Memory Heap[1]: 
info:      Size: 8176 MiB
info:      Flags: 0x0
info:      Memory Type[1]: Property Flags = 0x6
info:      Memory Type[3]: Property Flags = 0xe
info:      Memory Type[5]: Property Flags = 0xc6
info:      Memory Type[7]: Property Flags = 0xce
info:    Memory Heap[2]: 
info:      Size: 256 MiB
info:      Flags: 0x1
info:      Memory Type[2]: Property Flags = 0x7
info:      Memory Type[6]: Property Flags = 0xc7
0120:fixme:vkd3d_set_view_swizzle_for_format: Alpha swizzle is not supported.

Crashes for this versions :

  • lutris-ge-6.16-1_x86_64 : black screen at startup, at loading (but before enter in open world) and in game
  • lutris-ge-lol-6.16-4-x86_64 : black screen at startup and in game

sine you say Galaxy i guess you got it on GOG the GOG versions is shit I would recommend using the Steam version and then proton its works better but that game has never run well on Linux in my experience and its a buggy mess even on PC still after all the update it has gotten.

1 Like

Yes, it’s gog version (I updated the first post).
It’s possible to use Proton on Lutris ?

Have you tried install it like this-

I’m not 100% sure and I’m not sure if you need steam but go to lutris and say add new game then use the Steam to lunch the game and say it’s a DMR free game so it doesn’t open steam I have never tried it so idk if it works but that’s how i would do it.

The game does seem to be more stable when launched via Steam.

Thanks for the tip!

No Problem. i never liked the GOG version for many games have the same problem with Metro 3 on GOG

I understand …
But the fact that Steam allows “non-Steam” programs to be launched helps a lot.

1 Like

Agreed, but custom games cannot be configured as if you bought a game directly on steam.

Or i must do something wrong.