Back to the main site

[solved] Choppy / stuttering audio in Fallout 3 GOTY Edition (NOT radio)

I have been struggling with this for days. No that’s not right. It’s days this time around. Every so many months, I try to get this working again, but cannot. Then I give up for some more months. Last save game looks like Dec of 2019, which seems to be the last time I had this game working. So, in reality, I have been trying to get this to work for literally years now in fact. :frowning_face: :sob:

If I am understanding correctly, there are no installers for Fallout 3 which support DXVK. If true, that explains why I could not get that to work…

I can get the game to start using the installer for GOTY Edition. The audio in the launcher is fine. But as soon as I press Play and it goes full screen, I start to get really choppy / stuttering audio.

Here are all the things required by the sticky post: https://paste.ubuntu.com/p/hb7VKHfxhZ/ and https://paste.ubuntu.com/p/wJsqY88rkH/

And no, this is not just pertaining to the radio station (as I came across many references to that while searching, as it is apparently a common issue). In this case, it happens immediately upon starting the game.

Any tips would be greatly appreciated.

Have you tried the “Reduce Pulseaudio latency” option under Configure > System Options? That might fix general audio stutter. I needed that for certain games several times before.

I had kinda the same problem as you, except that my game would crash and not let me enter my save game. I’m not exactly sure what made it work for me, but here’s the steps I took.

I had first installed this
sudo apt install gstreamer1.0-plugins-good:i386 gstreamer1.0-plugins-ugly:i386

Then I’ve fiddled with the audio driver’s settings to see what would happen. At first, changing the driver to OSS made the game actually work and enter into my save game without crashing, but without any audio. Then I’ve enabled gstream there with the default driver, and I’ve started the game directly with the executable, so Fuse doesn’t reset it to ‘disabled’. After that, the main menu started to show the normal audio that it was supposed to, but I wasn’t able to load my save game, then after starting it with Fuse it all worked just fine.

I’ve been playing for around 12h these days with no problems whatsoever.

My guess is that PulseAudio might’ve f*cked some things up randomly, lol. Try to also restart your PC and not have it running to see if that helps.

Hope this works for you as well!

Thanks guise for replies.

Tried that, it did not seem to help. While I was in there, I tried a bunch of other things, too, which did not seem to help either (but I had done some of that before, too).

I know what OSS is, but not how to set it (instead of PulseAudio). And I thought Fuse was Filesystem in Userspace? You totally lost me there…

Around the time I made this thread, I had also replied in another thread to someone else. In the meantime, they got back to me. I tried the solution they suggested in that thread, and it worked!

I’m so happy! I have been wanting to play this again for so long!

Thanks everyone!

EDIT: I did not see any way to mark a post as the solution, so I edited the title.

Oh, my bad. I misspelled FOSE hahaha

Glad to know that you got it to work!