[Solved] Changed battle.net to beta version, won't display ui, can't change back

I have Battle.net installed via Lutris and it mostly works. Diablo3 and Diablo4 both work fine. Recently I tried installing WoW too via Battle.net, but it hangs during download.

In an attempt at troubleshooting that problem, I went into Battle.net settings and changed it to the Beta version and restarted it. Now it brings up the window frame, but cannot display any contents. Instead it displays a blank battle.net blue background, but no contents or controls, plus a Wine error dump dialog.

Is there any way to revert Battle.net back to the default non-beta version, without having to reinstall Diablo3 and Diablo4? Since I can’t access the Battle.net UI itself I’m not sure if this is possible.

There is, but this would need to be walked through on the lutris discord server in the #lutris_support area

1 Like

Thanks, I can log into lutris discord, should I just post this query there?

Solution from Discord:

  1. Uninstall Flatpak (and XDG portal if necessary. these may interact with lutris or battle.net improperly)
  2. Uninstall AMDVLK driver. (with it install, Lutris cannot use the Mesa open source driver, even if you manually select it)
  3. Use Mesa open source driver: Lutris β†’ Battle.net Configuration β†’ System options β†’ Vulkan ICD Loader = AMD RADV Open Source (MESA: RADV).
  4. Use wine-ge-8.22-x86_64+. Lutris β†’ Battle.net Configuration β†’ Runner options β†’ Wine version = wine-ge-8.22-x86_64
  5. Disable debugging output: Lutris - Battle.net Configuration β†’ Runner Options β†’ Output Debugging Info = Disabled. (optional but helpful for troubleshooting using $> lutris -d)