Back to the main site

[SOLVED] 'Can't Run The Sims 4 with the video card in this system' post update?


#1

I just got the My First Pet stuff pack, updated Origin (using a workaround from the top comment on the Origin winehq page to avoid having to reinstall again) and now whenever I try to launch the game it says:

Unable to start:
Can’t run The Sims 4 with the video card in this system. Please check that the video card meets the minimum specifications and that the latest video drivers are installed.
[0e6d1221:1df4e8dc:0000012d:912c9c10]

I wouldn’t think a stuff pack would up the video card requirements by much at all and it ran fine prior to this?

Things I’ve Tried So Far:

  • Running any and every updater I could find (firmware updater from the manufacturer, software updates, etc)
  • Running updates through the terminal
  • Trying to launch in windowed mode
  • Making sure that Origin In-Game hasn’t come back on somehow
  • Removing all mods and CC
  • Removing Config.log and Options.ini
  • Running the Origin update utility for the game
  • Running the Origin repair utility for the game

I also tried checking on the Intel site to see if my drivers are up to date but the drivers I have are OS supplied (Ubuntu 16.04) and I don’t kno how to find out the actual version. The newest versions for my graphics card (Intel® HD Graphics 620 (Kaby Lake GT2) ) are also only listed to download on the Intel site for Windows.

ADDITIONAL NOTE: I looked up the minimum game requirements both pre- and post-stuff pack, they’re the same so my card should definitely be good enough now since it was before.


#2

After talking to some people on a Linux gaming subreddit, I installed the mesa drivers and now it’s working so I’m going to am mend the title if I can.


#3

I am having this same issue right now after installing the game for my gf to play on my computer while i am gone. any link to the specific driver/file you installed