Back to the main site

[Solved] Cant run anything with lutris

Hi,
I am running Arch linux x86
using xfce desktop with xfce4 window manager

I have recently installed lutris to manage my windows games and so far its been fine.
Installing wine steam and origin work flawlessly but when it comes to running anything it seems to just crash.
like wine steam will allow me to login but then fails after that, and origin installed but wont launch.

i ran lutris in a terminal and tried running wine steam and i got this error
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: GLXBadContext
Major opcode of failed request: 151 (GLX)
Minor opcode of failed request: 6 (X_GLXIsDirect)
Serial number of failed request: 182
Current serial number in output stream: 181
[0321/225433.629:INFO:crash_reporting.cc(242)] Crash reporting enabled for process: gpu-process

i’v done some fiddling and got things like vulkan working but im stumped as to what to try next and dont fully
understand what im doing.
any help is really appreciated thanks.

Install lib32-nvidia-utils

1 Like

Thank you, that got it to start to but didn’t fully fix it.
Going to the arch wiki for wine really helped out for any one else who has this issue
Thanks for the help

Installing lib32-nvidia-utils did indeed fix the swrast dependency for me.
Thank you! running 5.5.3-arch1-1 nvidia mesa-utils