[SOLVED]Can't launch Witcher 3 with dxvk enabled

EDIT: Just realised the i didn’t had a wineprefix.

I’m trying to launch Witcher 3 with DXVK trought lutris but i recieve this error when dxvk is enabled:

INFO 2018-10-28 00:36:36,712 [dxvk]:Replacing drive_c/windows/system32/dxgi with DXVK version
ERROR 2018-10-28 00:36:36,712 [jobs]:Error while completing task <bound method wine.prelaunch of <lutris.runners.wine.wine object at 0x7fb95c09d898>>: [Errno 2] Nonexistent file or directory:: ‘/home/rodrigo/.local/share/lutris/runtime/dxvk/0.90/x64/dxgi.dll’ -> ‘drive_c/windows/system32/dxgi.dll’
<class ‘FileNotFoundError’> [Errno 2] Arquivo ou diretório inexistente: ‘/home/rodrigo/.local/share/lutris/runtime/dxvk/0.90/x64/dxgi.dll’ -> ‘drive_c/windows/system32/dxgi.dll’
File “/usr/lib/python3/dist-packages/lutris/util/jobs.py”, line 29, in target
result = self.function(*args, **kwargs)
File “/usr/lib/python3/dist-packages/lutris/runners/wine.py”, line 1135, in prelaunch
File “/usr/lib/python3/dist-packages/lutris/runners/wine.py”, line 1116, in toggle_dxvk
File “/usr/lib/python3/dist-packages/lutris/util/dxvk.py”, line 173, in enable
self.enable_dxvk_dll(system_dir, dxvk_arch, dll)
File “/usr/lib/python3/dist-packages/lutris/util/dxvk.py”, line 139, in enable_dxvk_dll
os.symlink(dxvk_dll_path, wine_dll_path)
ERROR 2018-10-28 00:36:36,712 [game]:[Errno 2] Nonexistent file or directory:’/home/rodrigo/.local/share/lutris/runtime/dxvk/0.90/x64/dxgi.dll’ -> ‘drive_c/windows/system32/dxgi.dll’
Gtk-Message: 00:36:36.718: GtkDialog mapped without a transient parent. This is discouraged.
ERROR 2018-10-28 00:37:16,563 [game]:Game prelaunch unsuccessful
Gtk-Message: 00:37:16.567: GtkDialog mapped without a transient parent. This is discouraged.

I’ve checked and all the dxvk files seems to be on they own folder.

Lutris use ~/.wine prefix, so you need to install DXVK manually in Wine installed in your system by using winetricks and untick Enable DXVK from all your games that uses DXVK, and games will start normally with DXVK ON.

This doesn’t make sense.

All the games should be installed in their own $GAME prefixes, usually located i ~/Games. Lutris creates individual prefixes for all of them and substitutes DXVK versions inside those prefixes.

It’s great that you got your game to work, but that isn’t the optimal solution for how Lutris works.

If I were to blame something, I’d blame this piece of the install script

arch: win64
exe: drive_c/GOG Games/The Witcher 3 Wild Hunt/bin/x64/witcher3.exe
prefix: $GAMEDIR

the exe: part PROBABLY could have been $GAMEDIR/drive_c etc, and instead is only “drive_c”, which could evote your “~/.wine” folder.

1 Like

I don’t use Lutris install scripts. I configure games that is installed before on my machine manually, and Luris always use my default wine configurations with all installed wine runners.

Alright. It’s always good to specify your steps when asking for help over here. We have no way to know you didn’t use the given install script for the game.

Glad everything is solved, have fun.