Back to the main site

(Solved) Can't install Overwatch with Lutris

I’ve downloaded the script:

lutris -i overwatch-installer.json

(lutris:31372): Gtk-WARNING **: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn’t be used anymore. It will be removed in a future version

(lutris:31372): Gtk-WARNING **: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn’t be used anymore. It will be removed in a future version

(lutris:31372): Gtk-WARNING **: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn’t be used anymore. It will be removed in a future version

(lutris:31372): Gtk-WARNING **: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn’t be used anymore. It will be removed in a future version

(lutris:31372): Gtk-WARNING **: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn’t be used anymore. It will be removed in a future version

(lutris:31372): Gtk-WARNING **: Theme parsing error: gtk.css:71:36: The style property GtkCheckMenuItem:indicator-size is deprecated and shouldn’t be used anymore. It will be removed in a future version

(lutris:31372): Gtk-WARNING **: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn’t be used anymore. It will be removed in a future version
INFO 2017-12-19 10:06:12,402 [lutriswindow]:Connected to lutris.net as parigan
INFO 2017-12-19 10:06:12,514 [lutriswindow]:Installing /home/user/Documents/overwatch-installer.json
ERROR 2017-12-19 10:06:12,552 [errors]:Missing field “runner” in install scriptNone

On “Select which version to install” doesn’t appear anything.

If I go to the website and click on Install:

https://lutris.net/games/overwatch/

I get the error:

err:module:load_builtin_dll failed to load .so lib for builtin L"WLDAP32.dll": libp11-kit.so.0: wrong ELF class: ELFCLASS64
err:module:import_dll Loading library WLDAP32.dll (which is needed by L"E:\\home\\user\\.cache\\lutris\\installer\\overwatch\\Battle.net-Setup.exe") failed (error c000007a).
err:module:LdrInitializeThunk Main exe initialization for L"E:\\home\\user\\.cache\\lutris\\installer\\overwatch\\Battle.net-Setup.exe" failed, status c0000135

EDITED:

Errors solved by installing the package libsasl2-2:i386 and its dependencies (done automatically by apt):

lutris:amd64 0.4.14
libp11-2:amd64 0.4.7-1
libroken18-heimdal:i386 7.4.0.dfsg.1-2
libasn1-8-heimdal:i386 7.4.0.dfsg.1-2
libgmp10:i386 2:6.1.2+dfsg-1
libnettle6:i386 3.3-2
libhogweed4:i386 3.3-2
libidn11:i386 1.33-2
libp11-kit0:i386 0.23.7-3
libtasn1-6:i386 4.12-2.1
libgnutls30:i386 3.5.8-6ubuntu3
libheimbase1-heimdal:i386 7.4.0.dfsg.1-2
libhcrypto4-heimdal:i386 7.4.0.dfsg.1-2
libwind0-heimdal:i386 7.4.0.dfsg.1-2
libhx509-5-heimdal:i386 7.4.0.dfsg.1-2
libsqlite3-0:i386 3.19.3-3
libkrb5-26-heimdal:i386 7.4.0.dfsg.1-2
libheimntlm0-heimdal:i386 7.4.0.dfsg.1-2
libgssapi3-heimdal:i386 7.4.0.dfsg.1-2
libsasl2-modules-db:i386 2.1.27~101-g0780600+dfsg-3ubuntu1
libsasl2-2:i386 2.1.27~101-g0780600+dfsg-3ubuntu1
libldap-2.4-2:i386 2.4.45+dfsg-1ubuntu1
libssl1.0.0:i386 1.0.2g-1ubuntu13.3 1.0.2g-1ubuntu13.3
libsasl2-modules:i386 2.1.27~101-g0780600+dfsg-3ubuntu1 2.1.27~101-g0780600+dfsg-3ubuntu1

Another error:

INFO     2017-12-19 11:56:21,606 [lutriswindow]:Connected to lutris.net as parigan
INFO     2017-12-19 11:56:23,987 [lutriswindow]:Installing None
INFO     2017-12-19 11:56:27,084 [interpreter]:Downloading file 1 of 1
INFO     2017-12-19 11:56:37,785 [wine]:win64 Prefix created in /home/user/Games/overwatch
err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.
fixme:ver:GetCurrentPackageId (0xc0e998 (nil)): stub
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform

EDITED:

Problem solved installing winbind:

winbind:amd64 2:4.6.7+dfsg-1ubuntu3.1

Finally could install Overwatch launching Lutris directly from the game page, clicking on Install. Apparently works better than the script. Of course had to install before the mentioned packages. I am surprised that Lutris doesn’t recommend you to install them before launching, probably is not able to detect that kind of things.

Game page: https://lutris.net/games/overwatch/

Make a HowTo for debian (distribution like) users (and note with these specific problems) and give people to update the information for better understanding (just building up the community really). Thanks for this information regardless, great job solving it.