Back to the main site

[SOLVED] Cannot launch lutris as non-root user on Arch Linux

Hello, I have issue with launching lutris 0.5.10 from offical repo as non-root user. If I launch lutris with sudo lutris everything work as expected, but if I run just with lutris this error message pops up:

Traceback (most recent call last):
  File "/usr/bin/lutris", line 52, in <module>
    from lutris.gui.application import Application  # pylint: disable=no-name-in-module
  File "/usr/lib/python3.10/site-packages/lutris/gui/application.py", line 36, in <module>
    from lutris.api import parse_installer_url, get_runners
  File "/usr/lib/python3.10/site-packages/lutris/api.py", line 9, in <module>
    import requests
  File "/home/lazbo/.local/lib/python3.10/site-packages/requests/__init__.py", line 43, in <module>
    import urllib3
  File "/home/lazbo/.local/lib/python3.10/site-packages/urllib3/__init__.py", line 8, in <module>
    from .connectionpool import (
  File "/home/lazbo/.local/lib/python3.10/site-packages/urllib3/connectionpool.py", line 29, in <module>
    from .connection import (
  File "/home/lazbo/.local/lib/python3.10/site-packages/urllib3/connection.py", line 39, in <module>
    from .util.ssl_ import (
  File "/home/lazbo/.local/lib/python3.10/site-packages/urllib3/util/__init__.py", line 3, in <module>
    from .connection import is_connection_dropped
  File "/home/lazbo/.local/lib/python3.10/site-packages/urllib3/util/connection.py", line 3, in <module>
    from .wait import wait_for_read
  File "/home/lazbo/.local/lib/python3.10/site-packages/urllib3/util/wait.py", line 1, in <module>
    from .selectors import (
  File "/home/lazbo/.local/lib/python3.10/site-packages/urllib3/util/selectors.py", line 14, in <module>
    from collections import namedtuple, Mapping
ImportError: cannot import name 'Mapping' from 'collections' (/usr/lib/python3.10/collections/__init__.py)

Am I missing some python package or does somebody know where is the issue? I tried reinstalling lutris multiple times, but still no luck

EDIT:
Bad info not from AUR, but from offical repo

why are you using Lutris from AUR?? Lutris 0.5.10 is on the official repositories! try using that version:
sudo pacman -S lutris

My bad, I checked and it’s from the official repository. The issue is still present

I don’t know why it’s not working and you shouldn’t be running lutris with sudo. I never had to do anything else than installing lutris using pacman:
sudo pacman -S lutris
it should resolve all dependencies but are you sure you have them? please check Arch Linux - lutris 0.5.10.1-2 (any)

I checked with sudo pacman -Qi lutris and it seems all dependencies are present

➜ sudo pacman -Qi lutris
Name            : lutris
Version         : 0.5.10.1-2
Description     : Open Gaming Platform
Architecture    : any
URL             : https://lutris.net
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : cabextract  curl  glib2  gnome-desktop  gtk3  mesa-utils  p7zip  psmisc  python-dbus  python-distro  python-evdev  python-gobject  python-lxml  python-pillow
                  python-requests  python-yaml  unzip  webkit2gtk  xorg-xrandr
Optional Deps   : gamemode: Allows games to request a temporary set of optimisations [installed]
                  gvfs: GVFS backend
                  innoextract: Extract Inno Setup installers
                  lib32-gamemode: Allows games to request a temporary set of optimisations
                  lib32-vkd3d: Vulkan 3D support
                  lib32-vulkan-icd-loader: Vulkan support [installed]
                  vkd3d: Vulkan 3D support
                  vulkan-icd-loader: Vulkan support [installed]
                  wine: Windows support [installed]
                  xorg-xgamma: Restore gamma on game exit [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 2.46 MiB
Packager        : Maxime Gauduin <alucryd@archlinux.org>
Build Date      : Tue 26 Apr 2022 05:48:40 PM CEST
Install Date    : Thu 04 Aug 2022 09:08:39 AM CEST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

EDIT: Typo

1 Like

I JUST FIXED IT!

I just needed to update pip packages with pip list --outdated --format=freeze | grep -v '^\-e' | cut -d = -f 1 | xargs -n1 pip install -U and it worked!

1 Like