[Solved] Black screen with Battle.net app (Not Hearthstone)

Hey all, I’m having issues installing Hearthstone and the Blizzard App I’m using the Hearthstone installer (tried both the 32bit and 64bit installers) as well as the Blizzard App installer. My install process goes as follows:
Run the installer (no issues, everything installs smoothly, no obvious errors in the log)
Try to run the game after install, get Bad EXE Format error
Download the Hearthstone (or the Blizzar App) install from the official site.
Run the hearthstone installer exe from lutris runner, this launchers the Blizzared App installer as expected.
Run through the Blizzard App installer which gets to the login page with no issues. Log in to the Blizzard App, this opens the blizzard app and I get a black or brown screen (https://imgur.com/nqc2lmB). Here’s the latest log from the terminal when the black/brown Blizzard App open (https://imgur.com/LcpLhed). Note that I can’t select anything from this screen so can’t try installing Hearthstone and running the Hearthstone.exe to bypass the blizzard app.
Also note I have triple checked I have all the required dependancies.

If anyone’s able to help me with this bizzare error I’d be greatful. I’m happy to provide more information if need be!

I updated my graphics drivers using the solution in (https://askubuntu.com/questions/980203/how-to-install-the-latest-intel-graphics-driver-in-ubuntu-17-10) and all was right as rain.


Here’s the full log output of the entire install process.

Blizzard App is 32 bit.

Bad Exe format means that you are trying to run 32 bit in 64 bit environment. You haven’t given any detail on what distro you are using, but setup your 32 bit Wine / Video drivers first.

Apologies, I’m using a 64 bit ubuntu 17.10 with intel HD graphics.
I’ve tried both the 32 bit and 64 bit versions, both had the same issue

Thanks Dox, I updated my graphics drivers to a newer version I didn’t know was available and everything is right as rain.!