[Solved] Battlenet missing digital signature

I’m trying to install WoW. I did install all dependencies.

I’m getting this error that the digital signature couldn’t be verified. I followed the link, for support: https://eu.battle.net/support/en/article/161075

Following the support post, gives nu help, as the certification is already installed.

Any suggesions?

None, never seen it before, never heard anyone complain about it. Try just deleting the prefix and installing it again, perhaps it has to do with the problem with Blizzard app and random config file corruption.

As in reinstall lutris? Becuase WoW is the first thing I’ve been installing.

No, the WoW install inside Lutris. Remove the game (this removes the prefix) then you try to install it again.

I’ve already tried that severel times without luck :confused:

lutris -d in terminal during installation of WoW, look at logs what you are missing.

It gets me nothing… o.O (Edit: Didn’t close lutris before the cmd. Trying again)

But here is two pictures:
I’m able to select language: https://prnt.sc/kophcs
Then it’s updating something (didn’t get a picture of that)
And finally his error: https://prnt.sc/kophcs

Same picture 2x…and anyways, logs.

Log: https://pastebin.com/DBk1yr65
Pic #2: https://prnt.sc/kopmbr

Whats your Lutris version?


What distribution are you using? And did you install Wine-Staging into your system?

I’m using Linux Mint 19 everything updated, and no I did not install wine-Staging.

Right, so, try installing Wine-Staging, then try installing again.

That was it! You got it working! Thank you SO much for your time!

Mark thread a solved please.