[Solved] Battle.net app - Can't find dependencies for Fedora 27

On Fedora 27, using Negativo17 nvidia drivers.
Have all of the dependencies I could find but couldn’t find a few from the ‘online access’ portion so guessing that’s my issue:

What repo should I enable for ‘libgnutls-devel libgnutls.so.28 libldap’?

The app prompts me for what language then gets stuck updating and generates error: BLZBNTBTS0000005C

Pastebin of Lurtris output:

The missing dependencies my issue? Can someone assist? Really want to ditch Windows finally but I needs my Overwatch lol.

The Fedora dependencies were provided by other Fedora users. If they ain’t available or not correct on Wiki, please figure out what it should be and update the wiki.

That said, looking at your logs, it seems you are missing video drivers, since you have glx errors. That means you probably didn’t install 32 bit drivers, for OpenGL / Vulkan.

Well may not be the most useful/apply to everyone but finally just did a system upgrade to Fedora 28 and seemed to fix everything lol.
Installed Bnet app and Overwatch and it’s running great(ish).

In case anyone stumbles here from Google:
I made sure that all of the various packages described at Negativo17’s site about Nvidia drivers, development packages, and 32-bit packages were installed.
Also made sure all the Battlenet app dependencies outlined in Lutris.net (what DNF finds) was installed as well.

Edit: Also unfortunately I’m terrible at troubleshooting things properly, I set SELinux to Permissive but didn’t try just rebooting/installing again before doing the upgrade process so that might had something to do with it too even though wasn’t getting any SEL warnings.

Edit edit: Okay OW working great even installed though the app instead of Lutris getting 120~ FPS. WoW though errors out with Streaming Error and had audio issues so just going to install via Lutris - now to figure out how to not have it reinstall a separate Battlenet app each time. But, progress!

Please mark your thread as solved.

The WoW streaming error solution is on the Wiki.

I’m using Fedora 28 and the dependencies were installed already or I installed them before trying to install a game. Though I will say libgnutls.so.27 was not found with dnf/yum and libldap I found as wine-ldap and openldap (not sure which one is required). However, when attempting to install Overwatch the Battle.net client install throws BLZBNTBTS00000011 which is referencing a missing ca root cert. I read somewhere that wine uses the host system trust store so I checked in /etc/pki/tls/cert.pem and the certificate blizzard mentions is in my trusted chain by default. I also saw that on debian based systems the trust store is /usr/share/ca-certificates/extra/foo.crt so I converted my pem in /etc… to a crt and stuck it in /usr… as cert.crt but this didn’t work. I would assume that the certificate would need to be trusted within the wine instance that is running for the “game”.

Have either of you run into this before and/or how do you remedy this?

I just wanted to chime in here and say that i have the exact same problem “BLZBNTBTS00000011”. Haven’t found any solution for it yet online, so if you or anyone finds a solution, point me in the right direction. I’ll do the same.

Edit: I’m on Ubuntu 18. All dependency’s from the github are installed.

Have you both installed Wine Staging into your system? Lutris can download specific wine versions, but installing Wine into your system pulls in “standard dependencies” that are not listed on the github wiki, since they are expected to be installed.

If you have, you can start looking at log, and see what it complains about.

Hi mate, thanks for following up. I’m actually unsure, which probably means no i don’t, I was expecting Lutris to have all Wine dependencies. I’ll check as soon as i get off work later today. Would it suffice to follow this guide, down and including the “Staging” section? Or is there any other / preffered way of installing Wine Staging you can link/show/point at?

Wine is the layer between the Wine application and your system. Lutris has versions of that layer, sometimes with patches to make games work, and / work better, faster, stronger. However, it translates certain calls into system calls, but if you don’t have the libs installed to receive those calls (the so called dependencies that you would get when installing Wine Staging), it will still fail.

On top of dependencies a Wine Staging install pulls in, it differs from distribution to distribution what “other” stuff it pulls in. Sometimes they are called “recommended” dependecies, sometimes stuff an application needs has to simply be installed manually. For Blizzard app it is listed on our Wiki, but if you are still missing something, the Wine logs should indicate it with “missing this / that”.

And I don’t care what some random guide you pulled from Google says, https://github.com/lutris/lutris/wiki has a wine page, and that wine page points to the actually winehq that should have instructions for your distribution.

PS: Lutris has a runtime, that has some/most of the missing dependencies. But it was created in a time when Lutris was less popular, and it is based on Ubuntu 16.04, which can give issues on other distros. So nowadays we advice people to install stuff into their system instead, since that is more up to date and works better all around.

1 Like

You Sir @Dox, is the hero I needed… not the one I deserved :slight_smile: I was missing Wine Staging. So I followed your advice and used the WineHQ Ubuntu guide that was linked in the Lutris Wiki WineHQ has guides for other distros here if anyone (@uberentwickelt) need them.

The Battle . net app installed without issues after installing Wine Staging. Have a great day @Dox, and thanks!