[Solved] Anno 1800 - Slow load times - Poor performace/Low FPS


While trying to run Anno 1800 load times are extremely long, up to 45 minutes on a large save file. On small files it will load in about 5 minutes but lags during play. FPS jumps from 90 to 1, then back and forth. On large files FPS is between 1-3. All with heavy stuttering.

I’ve tried running it under Windows 7 and Windows 10 on my Wine Configurations, as well as using the emulated desktop option in Wine. For my runner options in Lutris I’ve used Wine version lutris-5.7-10-x86_64 and WineHQ staging (5.18 (Staging)). I tried the Wine staging because of comments on the games install page but neither seems to run the game any different.

Here are some paste bins that will hopefully provide some insights:

Lutris -d output

Lutris --submit-issue

Any help is appreciated!

Here is the game debug log as well. Being a new user I couldn’t put 3 links in my original post.

Game debug log

I have confirmed that lutris-5.4-x86_64 runner fixes the problem. see ProtonDB reports:

Game needs wine-5.4 (or a fork of wine-5.4) or older version to work properly. Newer version of wine will cause much bigger save loading times.

1 Like

Yes that’s it! Changing the runner to lutris-5.4-x86_64 fixed almost all problems and the game is finally playable. Thank you so much!

Chiming in here to say this worked for me to. 6.0 rc1 was kicking me out after the first warning screen, and a few other versions I tried were taking forever at the loading screen.

Using 5.4 did indeed fix it for me, but I noticed that on dx12 I was getting warnings like this while in game terrain looked like it was missing a few odd textures in a check board like fashion;

d3d12_command_list_CopyTextureRegion: Depth-stencil format 0x13 not fully supported yet

Once I went in the game settings and changed it to dx11, all works well! So, just wanted to chime in and say thanks for the fix, works for me, and try dx11 instead of dx12 if you get a checkerboard like pattern of the game terrain.