(Solved) Age of Empires III (almost) black screen. 0 MB video ram

Hey everyone!
Ever since I reinstalled Arch I have nothing but problems with games that previously worked just fine when I ran them through wine.
One of these games is Age of Empires III. I’m running it on a clean 32bit prefix with d9vk (i get the same glitch without it). The game works just fine without mfc42 and l3codecx (I just skip the videos), but I tested the game with both installed.
The first issue is this:
Bildschirmfoto zu 2020-05-09 18-34-01

Initialization Failed. Direct3D initialization failed. Possible causes: Old or corrupted graphics driver. Direct3D improperly installed. Hardware acceleration disabled. Starting the application with the workstation locked. Please check the log file for more information. Age of Empires III requires at least a 64 MB video card. This computer appears to have a 0 MB video card. If you wish to upgrade your computer, please contact your computer manufacturer for any necessary assistance.

I found out that this error message occurs when Direct3D isn’t aviable here

When I click at “Attempt to Run” the game starts normally until I get to the main Menu:

I get a black screen with working buttons (I can click on them and the work, but there is a long delay) and the actually home city can be seen squished somewhere on the bottom.

Does anyone have an idea what I could do to fix this?

Here is the output of lutris --submit-issue https://paste.ubuntu.com/p/z5gyZBrgRn/

Alright, I got the game to run perfectly by just installing the game again (you have to keep the prefix).
go to your winecfg and increase the dpi setting under the graphics tab (so you can enter the serial key)
afterwards you just install l3codecx and you are set