Skyrim and doom4 [SOLVED - with answer]

I used the web install for fallout 4 and it is perfect.
I wish I could say the same for doom4 and skyrim.
The installers finish but neither game has dxvk turned on.
Also, skyrim was set to 32bit for some reason.
Neither will run.

Anyone have these running?

I don’t know about Skyrim, but DOOM uses Vulkan by default so it doesn’t need DXVK. I got it running under Wine 2.12-staging with PlayOnLinux and it runs flawlessly.

R u using steam? Steam will not run properly in wine-staging 2.12.
I did the playonlinux and 2.12 and all I get is a messed up steam screen and a black screen after I manage to get the game to launch.

It’s been a while since I played it so maybe an update messed something up. Check if you have Vulkan and mono installed, and that you’re using a 64 bit virtual drive. If so, try other versions of Wine.

EDIT: Also try following this tutorial in case the problem has something to do with missing Wine dependencies. This may seem obvious unless you’re using Arch.

I just got skyrim running.
I told fallout 4 (which already works) to leave steam running after I exit.
I used steam to “verify the skyrim local files” and one of them was bad. Steam fixed it.
It then prepared for the game with directx, vc, and .net.
I had to quit out of the prep window twice, but then the third time it gave me the options screen and I set it all to ultra and it ran.
So same wineprefix,wine, steam, and other settings as those provided by the lutris script on the main website for fallout 4 and then it runs fine.
I noticed that the icon was set to dxvk 053, but there is no 053, the highest is 052.
I may have buggered that entry by mistake.
Strange thing is that I cannot launch using the icon yet.
No problem, i will launch fallout4, exit and then launch it.
Anyway, launching a working game and leaving steam open afterwards seems to be a nice trick to get other games to work.
I hope that is helpful.
Doom 2016 is confirmed to have a new issue by gloriouseggroll. I met him on his twitch channel. He is very friendly and helpful.
I have been encouraged by him to install arch linux and compile his custom builds.
I know programming so maybe I can help in some way.

for some odd reason, I used the website install button and skyrim worked.
perhaps the bad file was the whole issue.
i noticed that the game is run as a 32bit game in windows xp mode.
that seems odd, but as long as it works.