Sims 4 Nov 13 update issues

Since I haven’t been able to find anyone else who has posted on this subject, I need to inform the Sims 4/Origin launcher team that Sims 4 no longer starts from Origin after the mandatory update which was pushed out by EA recently. (My info says it was delivered Nov 13)
I have gone though all the troubleshooting steps to try and isolate the source of the issue.
Working with a factory install (running Sims 4 with no content other than official expansions and packs, and no mods) Origin launches, but Sims 4 crashes at the ‘EA’ screen. I ran a repair cycle, verified files, made sure Origin In Game was off (both in Origin properties and the Sims 4 properties dialogs). None of these have worked, so I am left to presume that the recent patch has broken something in the way Lutris handles Sims 4.

Please note that Origin still runs fine, from both the Origin Launcher and the Sims 4 Launchers in Lutris itself.

It’s Sims 4 that has stopped working. I am not sure how to fix this issue, as Sims 4 generally runs perfectly in Lutris (better than native Wine and POL). I’m willing to help any way I can.

Also, I checked on a Windows 10 install and Sims 4 runs fine after the patch.

Please feel free to contact me with any questions or suggestions.


hello! i’m just a Sims player, so i’m sorry for not writing anything useful. everything you mentioned is the same on my end.

TS4 has been updated to use Python 3.7. i have read that other people on Windows are also reporting crashes, glitches, or that their (un-modded) games are not launching at all.


Thanks, unseenlarks. That’s actually helpful, knowing other Windows users are having issues as well. My husband’s computer is just lucky, it seems.

My sister and I are both having this update issue too. Didn’t think to check here first because its usually only Origin updates that give me trouble.

It does seem to be related to the new Python update. I’m getting the following issue:

wine: Call from 0x7b44abbc to unimplemented function api-ms-win-core-path-l1-1-0.dll.PathCchCanonicalizeEx, aborting
wine: Unimplemented function api-ms-win-core-path-l1-1-0.dll.PathCchCanonicalizeEx called at address 0x7b44abbc (thread 005f), starting debugger…

Which a Google search reveals to be a bug in the way WINE handles Python. Link to Bug


Thanks for the new information, Draconicrose. Hopefully someone more talented with Wine and Python will be able to solve this issue soon. <3

1 Like

It seems someone has been working on a patch that another user tested with Sims 4 and said works. I, unfortunately, don’t know how to use it so I can’t confirm or deny but the git repo for the patch is linked at the bug page that Draconicrose shared.


I’ve noticed that the installer thing on the game page for Sims has been updated to Gold now from the Garbage rating its had since the new patch broke it but I’m still having this issue and the commented issues on the page aren’t marked as resolved.
Do I need to do something to ‘update’ the install I have (preferably without having to reinstall the game because its massive when you have all of the expansions and such) to get it to work or did someone just luck out, not get their game broken by the patch, and update the status on the page reflecting that?

it now works with wine version
tkg-sims4-3.20-x86_64 for me at least


thank you!