Back to the main site

Shattered Steel Installer Locking up During Install

Hello all,

I’m using Mint 19.3, with the Cinnamon UI. I’m trying to use the installer for Shattered Steel, off GOG. The installer appears to setup a few settings in dosbox, then asks for the install file. Once I hit install, choose where to install the game, then click next, the installer locks up. This is the step where it should be asking for the installer provided from GOG. Instead it just sits there. No other windows come up, and the screen doesn’t change (outside the buttons changing).

Tbh, I’m not sure how to trouble shoot this, and google isn’t being helpful either. Is there a way to force the installer to the next step? Can I install the game using wine, then simply import the settings dosbox needs?

hokay, so far as I can tell from here, I’ve configured the game like the installer would. My Main file is: .wine/drive_c/GOG Games/Shattered Steel/DOSBOX/dosboxShatteredSteel_single.conf, my Config file is .wine/drive_c/GOG Games/Shattered Steel/dosboxShatteredSteel.conf, and my config has the following text in it:

[IPX]
ipx=false
[autoexec]

Lines in this section will be run at startup.

@ECHO OFF
mount C “…”
imgmount d “…\SSTEEL.inst” -t iso -fs iso
c:
cls
ssteel.exe
exit.

Sadly, its still not opening the game. Dox box launches, then immediately closes again. No Output to the screen. It does lock my mouse though.

Still trying to figure this out.

Ubuntu Pastebin Link. Also, when I run the log when running the game, the only output I get is: